Automations broken?

Topic Labels: Automations
5025 32
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

Yesterday I build a number of automations that I fully tested and worked fine but are now broken.

Trigger is new record in a view
Action is update record
What breaks is identifying the record. I want to update 1-2 records that are linked to the trigger record. Since you cannot use a link in the record ID column I have a look up of the record ID.

I now have 2 issues.

  1. The links are showing as not valid (picture 1) where yesterday this was totally fine
  2. I cannot click to add the values. There is a open symbol but when I click it, nothing opens.

Of course I publicly launched the process that relies on these automations today so it’s critical I get resolution to this ASAP.



32 Replies 32

I think it might just be an issue with the lookup fields - they don’t seem to play nicely with automations when trying to retrieve values out of them.

Try making formula fields that just point at your lookup fields (pulls the values from the lookup fields), and use those in your automations instead.

I answered within 10 minutes of you posting, and you seemed to indicate there was some urgency here… did this work to resolve your situation?

Yes! Thanks a million!

4 - Data Explorer
4 - Data Explorer


Hello Jeremy
We are facing the same problem. Since this morning, most of our automations broke.
We were already pulling value (emails) from look up using a formula field. An automation copy/past this formula field value into a TxT column (so we have emails under a text format). An other automation was supposed to send an email to these emails and this automation is now showing an error and an empty “To” field : it seems the automation cannot pick data from a text field anymore.

This is a critical issue as this base is a client base, already rolled-out and our client is actually mad, as we are, that Airtable rolled out an update breaking former automations. Even our snapshots or previous back-up are now showing broken automation. We need assistance, please !

4 - Data Explorer
4 - Data Explorer

I encountered the same issue in the automation. I was trying to do cross table automation, and I cannot get the LinkedRecordId. I don’t know how to use formula field to achieve the same goal.

My setting is that: Table B has a linked field back to Table A. When I add an entry to Table B, I will specify the linked record in Table A, and I want Table A record update some value when the entry is added to Table B. How can I do that using formula field instead of linked field?

6 - Interface Innovator
6 - Interface Innovator

HI All,

Jeremy’s solution is currently working for me though it is a bit clunky.

I have my linked field.
I have another field looking up the record ID
I have a third column that is a formula of the record ID field.

I am now powering my automations using the formula field




5 - Automation Enthusiast
5 - Automation Enthusiast

I’m trying this approach and it’s not working for me. The automation fails with the error message “The record does not exist.”

When I compare the Record ID that’s being output to the actual record ID in the target Table, it matches exactly, so I’m not sure why I’m getting the error.

Is this approach still working for others? Maybe there’s something I’m not formatting correctly?

Hi William,

Can you please explain me how you automate your copy/paste from a formula field into a txt column?

Right now, I’m stuck with an automation because of an email field I retreived from a lookup, that I transform with a formula. But when I use it in an automation, it doesn’t work (actually the mail doesn’t show up)

5 - Automation Enthusiast
5 - Automation Enthusiast

@Gabi_Messina, Airtable says that you cannot use lookups that return more than one result (as for that matter, the same happens to Rollups, even if you convert the array to a string).

You can check this out here:, in the last section.

This is unfortunate. I’m trying to automate a function that needs to send an email to more than one person, based on a lookup and it simply doesn’t work anymore.

Hey Cedric,

I am pretty sure your automation is working, but the testing function of your “send email” is failing. Try to enable it even if it fails. Plus, be sure to have at least one record containing an email adress on the specific view you are using (if you are using when records enters view)

Hope this works,


It did work!

You’re right, the test is failing, but the email is sent.

Thx William :slightly_smiling_face:

You are very welcome !
Do not hesitate if you seek help, we cracked a lot of things around automations already :heart_eyes:

Télécharger Outlook pour Android

@Jeremy_Oglesby and @Gabi_Messina is this solution still working for you? I have replicated it exactly but I’m getting an error on runs: “The record does not exist.”

6 - Interface Innovator
6 - Interface Innovator

Thankfully this is still working for me but I am pretty sure I ran into issues building a new automation using this method.

In my case I was able to find another workaround that worked well. Automations can pull a record ID if it is text in a single line field. In my case I was able to have the record ID pasted into a field as part of the automation and later pulled that field to use for another update action.

Hope that makes sense/ potentially helps.


Ah, that’s brilliant! I just tried it and it’s working for me. Thank you so much for this update.

As an aside, I’ve realized that part of my trouble is that I was trying to do this using a synced table, and I made the mistake of assuming that Record IDs in a synced table would be identical to Record IDs in the original table it is syncing with with. That’s not the case, which is why I was getting the “The record does not exist.” error.

When I adjusted it to lookup the record IDs for the synced table instead, the automation was able to find the proper records! But now I’m running into a different error: “Updating the record failed due to insufficient permissions.” Which I’m thinking means that automations can’t (yet?) edit fields in synced tables.

I went back to the original base and set everything up there, and works perfectly.


It’s not just Automations that can’t edit the fields in synced records, it’s anybody. A synced table is meant to be edited only from the originating side of the sync relationship. If you are trying to update the fields on the receiving end of a Synced table, the Automation won’t be able to do that.

However, you could use a Script action in your Automation, and in your script utilize Airtable’s standard API to find and update records in the originating base/table for the records you see synced into this base. If you update them in the originating base, when the sync is next updated, you’ll see those changes reflected in the receiving Synced table.

Thank you for this note @Jeremy_Oglesby! Really good to know this.

6 - Interface Innovator
6 - Interface Innovator

Hi all, I am having a related but different issue with Airtable Automations, and would welcome any thoughts on whether user error or bug! Hopefully I am sufficiently on topic here and not too verbose…

I am using the “create record” automation to create a new record in a “timesheet” table, based on moving the status of a job in a “jobs” table. I also write the Record_ID of the new timesheet record in a field of the “jobs” table (single line text). So far so good!

The trouble starts when I want to then use an automation to “update record” (the one I just created).

The “action” of the “update record” automation connects to the timesheets table. It pulls through the Record_ID of the relevant timesheet record, the one that I have saved in the “jobs” table from the first automation (see above). The problem is that the Record_ID field appears to the automation to be blank even though I can see it in the table.

If I manually type the Record_ID text in the automation this works.

So it seems to be that the first automation creates a field Record_ID entry that is visible to the eye but not the automation.

I tried passing the Record_ID via a second formula field, and it didn’t work. I tried ignoring the test result and just running and it didn’t work.

Any thoughts / advice appreciated!


If it helps the usecase is that I want to create a timesheet entry when dragging a “job” into a kanban category “timer”, and record the time at which this is done. Then when the job is dragged out of the “timer” category, the same timesheet record is updated with the end time. One minus the other = duration. As I am on the free version at the moment Apps are not available.

Automation error

Hey @Anthony, I’m not nearly as experienced with Automations as others on this thread who might see a clear error, but I did have one idea. I’ve had a couple of automations on brand new records fire too quickly, before the data in my fields has been set. Could it be that the automation is triggering before your “Timesheet record ID passthru” has been filled in?