Help

Update a record with script output, not updating correct field?

Topic Labels: Automations
Solved
Jump to Solution
4838 11
cancel
Showing results for 
Search instead for 
Did you mean: 
Kris
6 - Interface Innovator
6 - Interface Innovator

I’m a little bit lost on this one and hoping for some help from the community. I’ve been using this automation without issue for months, but recently something changed and now it’s throwing me an error. (I’m guessing something updated on Airtables end).

I have an automation which runs whenever a customers record is updated (which includes a rollup field of their orders). I then run a script to take the customers linked order records and sort them, so that newest orders show at the top. Up until this point, everything is working as expected, and the output of the script is a sorted list of the linked record ‘names’ (which in this case are Order ID’s, like 12345).

The next step, ‘Update a record’ is where I’m now getting the error everytime this automation runs. It should (as before) take the output of the script and update the linked ‘Orders’ field in the customer record that changed, triggering the automation. That’s all it does, not changing any other fields.

Now, I’m getting an error saying: ‘Field “Order ID” cannot accept the provided value: Cannot modify a computed field.’

The confusing part, is I’m not trying to update any Order ID’s (which are only a field in the Orders table, which is not even what I’m updating). I’m only updating the ‘Orders’ field in the Customers table for whichever record triggered the automation.

automation-fail

Any idea what might have changed to cause this? Or, any ideas to work around it? The outcome I want is just to update the linked ‘Orders’ field in a Customer record with my sorted list.

Let me know if you have any questions or need more information. Any and all advice is welcomed and appreciated. Thanks!

Edit: Looks like there are several others who have run into this issue after something changed recently. It seems that using the record ID’s directly in the linked field may be a solution, but unfortunately for me I need to use the record ‘names’ to sort it properly (ie, 10003, 10002, 10001).

11 Replies 11
Kris
6 - Interface Innovator
6 - Interface Innovator

@kuovonne I actually did attempt that, but the same error was thrown (when trying to update a linked field with a list of record ‘names’).

The good news, is that Airtable appears to have fixed whatever was causing this behind the scenes.

The automation is now working as it was before. 😃 Thank you all for trying to help in the meantime, I really appreciate this community of awesome people.

Glad that Airtable’s fix worked for you. However, if anyone stumbles across this thread in the future, I want to clarify that I was suggesting that the script updating the linked field with an array of Airtable’s internal record ids, not record names. If a script has record names, it can match up record names with ids (or extract the ids at the same time as the names).