Android app can not attach local non-image files to Tasks or Projects

Topic Labels: Base design
1852 7
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

I’m using the app on Android, and have a file (pdf) on my device I want to use on my task, but the only local files the app lets me attach are images. Why?

7 Replies 7

Could you leave an screenshot? I can add anything:


NO. Every time I try to add images to the post is gives me an error and says I can not add images to the post. Here is what I did… I will try to add images after and see what happens:

First I added a field called Local Files and set its’ type to Attachment.

Next I select the hamburger and am given a list of external storage providers

Finally I select the other option that isn’t a camera, and browse to the pdf I want to attach, but it is greyed out and can’t be selected.

5 - Automation Enthusiast
5 - Automation Enthusiast

Nope. Board here won’t let me add pictures. I don’t know why.

Use an external site like

Oh yes. I’ve just tried and:

  • Push in Image icon, try to add a PDF and I can add it, but as image. So it does not show the preview, I can’t open it, and if I try to download the app restarts.
  • Push the 3 dots menu, and there only appears online services to add files.

So bad :frowning:

4 - Data Explorer
4 - Data Explorer

Nearly 2 years later and this is still an issue, perhaps even worse than before? I don’t know when AT removed the ability to upload non-photo docs without 8 extra steps to upload it to a DIFFERENT cloud, but it’s absolutely ludicrous that is the case. I’m so angry to discover this, as I am often locally editing documents on my phone and need to be able to put those changes on a record IMMEDIATELY, not when I get back to my desk at some random time in the future.

What’s the point of paying for pro if I can’t actually use half the functions or have to pay another service for cloud storage first to use it on mobile? The idea that I should have to put my files on IG or Facebook?? Awful design methodology here.

I’ve just tried and could upload a PDF from the “Photos” option. You can choose any file from there. I think is just a naming (and icon) problem: