Re: Import does nothing

1105 0
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

I am creating a new base by importing an excel sheet. When I select import from the wizard or from table tab carrot menu or from "add or import" button to the right of the table tab, there is no dialogue box...nothing happens.


Thanks all!

2 Replies 2
Community Manager
Community Manager

Hi @John_Ukos 

In order to get to the bottom of what’s happening here, I'll need to gather a bit more information. Please try the following steps in order and let me know if this clears up this issue (it will also be helpful to know which step worked if that’s the case).

Troubleshooting Steps:

  • I'd like to see if a hard refresh of your cache will resolve the issue. From your Airtable tab, you can do a hard refresh by holding the ⌘ Cmd and ⇧ Shift keys and then pressing R. If on a Windows device, the shortcut to hard refresh a page is Ctrl + F5.
  • Try using an incognito window / a private browsing window / safe mode to see if this issue still occurs.
  • Does this happen in another browser?

If that didn’t help, please send over the following information:


4 - Data Explorer
4 - Data Explorer

Hi Vic, 

Tech requirements met for browser's

tried on Chrome and Edge

performed hard refresh

does not work in incognito mode.

does not work on other pc's in our office.

This does work on my home pc so suspect our network is blocking something.

Thank you , John