Airtable to Power BI "Expression.Error"

2205 1
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

I followed the directions from this handy Airtable Support Page: Sending Airtable data to Microsoft Power BI & Power Query to get data from one of my tables to Power BI.

It worked perfectly. Then I transformed one field/column on Power BI by mistake, meant to transform it from text to number but instead I chose binary. I am quite new with Power BI and SQL–anyways I tried to ctrl + z to revert but I wasn’t successful. So instead I just closed it all out and left it unsaved, but of course when I opened it, the mistake change was still there.

So then I exited out of Power BI and started a completely new Query, basically redoing everything I did from the Airtable Support steps above, but now the Table_ID parameter always gets a triangle with an exlamation point after I copy in the M Query and click “Done”. I also get the following error message: “Expression.Error: A cyclic reference was encountered during evaluation.”

I’ve restarted my computer and tried everything again, and still get this message. It’s odd because I’m doing exactly the same thing I did when it was successful the first time. What am I getting wrong here?

1 Reply 1
4 - Data Explorer
4 - Data Explorer

Did you ever get a solution to this?  I am having the same issue.