Help

Re: App localhost certificate error

Solved
Jump to Solution
1328 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Sticker_ninja
6 - Interface Innovator
6 - Interface Innovator

Hello! When attempting to edit an app, I enter https://localhost:9000 into the Edit app dialog box, and I’m getting the following message:
Screen Shot 2021-01-20 at 6.27.50 AM

As well, I run into this screen when going directly to https://localhost:9000 in Chrome:
Screen Shot 2021-01-20 at 6.34.58 AM

This did not occur previously. I’m not sure what happened but I don’t know what I’m supposed to enable. There doesn’t appear to be an allow-insecure-localhost flag when I go chrome://flags/#allow-insecure-localhost. Any idea what might be causing this?

1 Solution

Accepted Solutions
Erin_OHern
6 - Interface Innovator
6 - Interface Innovator

Here is a workaround that should work for Chrome in the meantime! More information on can also be found in that thread – looks like it is a bug that the flag was removed in Chrome v88.

See Solution in Thread

7 Replies 7
Erin_OHern
6 - Interface Innovator
6 - Interface Innovator

Hi all,

Erin with Airtable support here :wave:

I’ve already been in touch with Michael about this issue but wanted to post here as well in case others are running into the same thing. The allow-insecure-localhost flag was removed in the latest version of Chrome (v88), which caused this issue. Our team is working on a fix for this to enable custom app development in Chrome without this flag, and that fix will hopefully be released by early next week. In the meantime, we recommend using Safari or Firefox to develop custom apps, or downgrading Chrome to v87.

We’re very sorry for the inconvenience this caused! Thanks again for reporting this.

Erin_OHern
6 - Interface Innovator
6 - Interface Innovator

Here is a workaround that should work for Chrome in the meantime! More information on can also be found in that thread – looks like it is a bug that the flag was removed in Chrome v88.

That workaround allowed me to access an app on Airtable. Thank you.

JSKY, I also ran into a similar issue for both Safari and Firefox. I’ve included screenshots of both.

Safari - Screen Shot 2021-01-25 at 1.50.09 PM.png

Firefox - Screen Shot 2021-01-25 at 1.51.34 PM.png

Marielle_Gueis1
6 - Interface Innovator
6 - Interface Innovator

Hi @Erin_OHern, I'm facing the same issue at the moment in Chrome and Safari. The link you provided is not available anymore. Any tips on how to fix this? 

Like Marielle, I have the same issue and the link isn't working.

 

geophreigh
4 - Data Explorer
4 - Data Explorer

I'm also experiencing the same issue. I think it may be worth opening a new thread related to this one since this is from 2021.

geophreigh
4 - Data Explorer
4 - Data Explorer

@Marielle_Gueis1 and @Bruiser_Chris I was able to get this working by enabling the following flag:

chrome://flags/#unsafely-treat-insecure-origin-as-secure

Restarted the browser for the setting change to take effect and I am now able to load the app successfully.