Re: Authentication required

7395 0
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

when i create records,got a reeor about Authentication,the message is:{“error”:{“type”:“AUTHENTICATION_REQUIRED”,“message”:“Authentication required”}}

this is my code and data:

url = “
h = {
data_list = {“records”: [{“fields”: {“Name”: “a”, “Priority”: 3}}]}

13 Replies 13

You’re not using the right syntax for any of those lines.

Go to and it will give you the appropriate syntax to use for each one of your bases and for each function you want to perform.

I developed it based on the API

Can you tell me what’s wrong


On first glance, it looks a bit odd until you realize this is Python.

Hi @wenju_fan, and welcome to the community!

I believe this is Python because the json.dumps() method caught my eye and this only exists in Python. Can you confirm this is Python?

I believe the issue is in the header - change it to this:

'Authorization' : 'Bearer ' + cAirtableAPIKey,

Yeah,this is python
as you said,I tried this:


If you have a demo,i will appreciate it if you can send me a copy



Okay - let’s be sure about your code - can you publish the latest version?

4 - Data Explorer
4 - Data Explorer

the syntax looks fine. Probably you got the key or the url wrong.

5 - Automation Enthusiast
5 - Automation Enthusiast

I’m running into the same issue when making any API call in the iOS Shortcuts app on my iPhone, but it works fine with curl and Postman, and even Shortcuts on my Macbook.
header: “Authorization”:“keyxxxxxxxxxxxxx8Ng”,

I’ve double and triple checked and copypasted the url and key between the apps where it works and the ones where it doesn’t, but nothing changes

It looks like you are missing the word Bearer

Good catch, though in this case I had just forgotten that when typing out the question, I actually do have the Bearer included in Shortcuts and the other places mentioned.

I have narrowed it down to an issue not related to Airtable (so feel free to skip reading if you’re not familiar with Shortcuts):
I have several shortcuts (think of them as scripts) that run another shortcut inside to pull in a dictionary object containing some variables like the API key, and then the main shortcut plops that into the Authorization header for the API call. But there appears to be a bug in the iOS version of Shortcuts right now that is making it impossible to pass variables from an inner shortcut to the outer shortcut that just ran it.

For example I can show this pair of test shortcuts doesn’t pass the dictionary value correctly:

I’ll be making a support request to Apple to fix their bug,

4 - Data Explorer
4 - Data Explorer

i am trying to retrieve a base from my airtable in Node.js
const fetchCourses = () => fetch(“”);

and this is the error i am getting

{“error”:{“type”:“AUTHENTICATION_REQUIRED”,“message”:“Authentication required”}}

Were you able to figure it out - currently trying to set up a Shortcut on iOS. Getting the same error.