Re: Automatically create a new record - processing error 422

2184 2
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast


I’m trying to automatically create a new record in “Table 2” whenever another record is created in “Table 1”.

Both “Table 1” and “Table 2” are in the same base.

I’m using Zapier for this:
-Trigger: New Record in Airtable
-Result: Create Record in Airtable

I’ve tried various options for this, but always get the same error message - see the below text.

My suspicion is that this is due to some formatting point - where Zapier is trying to pass Airtable some field value which Airtable believes to be inconsistent with the table’s rules.

I can’t see any obvious error in my set up however…one thing to note is the “Task ID” field which I’m feeding is a “Linked Field”…not sure if this could be an issue?

The output of this zap is currently nothing ie it’s not having any impact or triggering anything in my base

Thanks in advance

We had trouble sending your test through.

The app returned “Unknown field name: “fld9uHctoXMIDGpAq””. This can occur if the information entered into a field is not in the correct format. Double-check that you are using the correct format for entering values into a field.

We made a request to and received (422) Unprocessable Entity.

4 Replies 4

Hi @Darius_Safavi - the Zap is looking for the field name “fld…” which is the internal Airtable field ID, I think, rather than the field name. As you say, I think this is probably due to the Task ID being a linked field.

Can you provide some more detail on your table set up - fields, type, links etc and what data you are passing from table 1 to table 2?


5 - Automation Enthusiast
5 - Automation Enthusiast


Attaching some details of the 3 tables involved in this set up (the 3rd table not mentioned before is actually where “Task-ID” is being pulled from into “Table 2”.

In short, what I am wanting:

  • Every time a new client record is added to “Table 1”
  • A new assigned task record should create itself in “Table 2”, where the majority of the attributes of this record are pulled through using “Lookup”

Many thanks for the helpScreenshot 2020-01-08 at 11.31.24 Screenshot 2020-01-08 at 11.31.30 Screenshot 2020-01-08 at 11.31.41 Screenshot 2020-01-08 at 11.29.43 Screenshot 2020-01-08 at 11.29.55


Hi Jonathan

Was just wondering if you’d had a chance to review my query at all?

Many thanks

Hi @Darius_Safavi - I got this to work, hopefully with the same/similar setup as you. I’ve got a Clients table:

Screenshot 2020-01-10 at 12.56.24

and a Tasks Library table:

Screenshot 2020-01-10 at 12.57.00

and, finally, the Assigned Tasks table:

Screenshot 2020-01-10 at 12.57.57

In the Assigned Tasks table, I want Zapier to create a record and pass the task ID and the Client ID through to the record. I can then look up Task Name (from Tasks Library) and Client Name (from Clients).

In Zapier I have this:

Screenshot 2020-01-10 at 12.59.49

Screenshot 2020-01-10 at 13.00.48

Screenshot 2020-01-10 at 13.00.55

So, the task ID is a constant value (and a valid Task ID in Tasks Library). The Client ID is the ID from the new Client record. The ID and Autonumber fields should be left blank as these are set by Airtable in Assigned Tasks. The Task Name and Client Name Lookup are both lookup fields so these should also be left empty.

When I create a new client and Zapier runs, I get this:

Screenshot 2020-01-10 at 13.04.06

Contrary to what we talked about earlier, I wonder if the error you were getting is down to an old/missing field?

Unknown field name: “fld9uHctoXMIDGpAq”

Try refreshing the fields in Zapier to get the latest table definitions from the base.

Hope this helps.