'block run' command leading to errors

Topic Labels: Custom Extensions
704 0
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer


I’ve tried installing and launching a hello world app from the documentation for the first time today. I encountered a few issues initially trying to install the CLI, however I eventually seemed to get it working.

The issue I’m having now is with the ‘block run’ command - after successfully using block init, the block run command leads to a large amount of errors which seem to stem from a few files not being found during the start of the process:

/Users/craigronald/.nvm/versions/node/v13.14.0/lib/node_modules/@airtable/blocks-cli/transpiled/src/builder/node_modules/yaml/index.d.ts: Cannot read property 'get' of undefined

/Users/craigronald/.nvm/versions/node/v13.14.0/lib/node_modules/@airtable/blocks-cli/transpiled/src/builder/node_modules/yaml/types.d.ts: Cannot read property 'get' of undefined

/Users/craigronald/.nvm/versions/node/v13.14.0/lib/node_modules/@airtable/blocks-cli/transpiled/src/builder/node_modules/word-wrap/index.d.ts: `export =` is not supported by @babel/plugin-transform-typescript

Please consider using `export <value>;`.

I tried using nvm to change the version of Node, I tried builds from Node 12, 13 and 14 however all of them broke at the same stage.

I decided to delete nvm and instead installed Node v14.16.0 from the nodejs website, setting the $PATH to ‘usr/local/bin’, so it pointed to the newly installed version.

After getting around a few issues with permissions, I managed to install the CLI, and ran the block init command. Finally I tried to run block run again, hoping this time it’d work, but I got the same errors as before.

Any help would be greatly appreciated, I’ve wasted a day trying to get this work.

Thank you,

Edit: One of my colleagues was able to set up a new block on his system without any problems. He sent me the files which were created using block init, and when I tried execute ‘block run’ within the downloaded folder, it worked straight away.

0 Replies 0