Re: BUG - can't load record into app from button in expanded record

1038 0
Showing results for 
Search instead for 
Did you mean: 
7 - App Architect
7 - App Architect


This used to work and stopped. Tried it with a new app and button too. Whenever I click an open app button when the record is expanded, it seems that the window message with the record id is not delivered to the app. I get the following error in the console:

Failed to execute 'postMessage' on 'DOMWindow': The target origin provided ('') does not match the recipient window's origin ('').

The app DOES open in the extensions dashboard when clicking an app open button from the grid view.

2 Replies 2
Airtable Employee
Airtable Employee

Hi Ronen,

Thanks for the report. I tried the analogous interaction (click a Button Field to open an app when a record is expanded) in a few other extensions:

  • Scripting
  • SendGrid

In both of those, the same “Failed to execute ‘postMessage’ on ‘DOMWindow’” error also appeared, but the extensions also did get the record data correctly.

This makes me wonder what the code looks like in your app for receiving the record data, since we have 2 available in the blocks-sdk:

Hope this helps us move along here. Thanks!

Hey again Fred :-),

Thanks for taking the time. I’m using registerRecordActionDataCallback and am not getting the callback.