Help

Airtable Cobuilder is here! Learn more about our new no-code app creation feature, powered by AI on the Airtable Academy

POST problems using Google Apps Script

Topic Labels: API
2481 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Christopher_Bue
4 - Data Explorer
4 - Data Explorer

I’m trying to create a front end webapp for collecting sign up information and storing it in AirTable but can’t get AirTable to accept my post request. Originally, I had all of the field value pairs directly in the payload. Oops! I have since then created the fields object with field value pairs inside of it but keep getting INVALID_REQUEST_UNKNOWN. The message reads that the parameter validation fails.

I’ve even gone so far as to copy and pasting the example object code from the API doc’s to make sure I’m using the exact names and data types of fields but receive the same error!

I’m not trying to add data to any formula, rollup, or lookup fields that can’t be edited.

(I tried to use AirTable.js by pasting the source code but GAS didn’t like that and kept throwing me random debug errors)

Any ideas??

0 Replies 0