POST with alteryx & returning 'validation' and 'fields not found' errors

Topic Labels: API
2787 3
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

Preface: this is the most frustrating API to POST to I have ever worked with, it’s incredible.

I am attempting to POST a new record using Alteryx (a workflow tool with cURL’ish functionality) and I keep getting 1 of two errors:

{"error":{"type":"INVALID_REQUEST_MISSING_FIELDS","message":"Could not find field \"fields\" in the request body"}}

Or, when I re-aliased the alteryx field from “data” to “fields” -

{"error":{"type":"INVALID_REQUEST_UNKNOWN","message":"Invalid request: parameter validation failed. Check your request data."}}

Here is the data I am POST’ing:

"fields": {
"Program Name":"Education Test",
"External Id":"a00ie00QA4"

This exactly conforms to Airtable’s spec and I am still getting errors. Do you have any suggested approaches for troubleshooting or resolving this?

Edit: worth pointing out that I have been able to successfully POST using Postman, but I am blocked when I am trying to “Productionalize” this in alteryx

3 Replies 3
4 - Data Explorer
4 - Data Explorer

I ran into this as well. The API is pretty simple. For me the issue was that I didn’t set the content type to json.

Content-Type: application/json

Thanks @John_Fuller, amazingly that worked. I had previously set the header to be

Content-type: application/json

In the alteryx download tool when I was experiencing this issue, and then I changed the header key to Content-Type and I was able to POST to airtable successfully

Was the capital “T” the difference maker?

Out of curisoity, have you solved this problem specifically with airtable and alteryx?

same – capitalization was key for me, setting content_type using needle didn’t work.