Uploading attachments via API not working consistently

Topic Labels: API
3663 3
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

Using the API to upload PDF files. Every couple days a batch of files uploaded around same time appear as generic document icon and when you attempt to download you get “Found. Redirecting to” message but nothing. If I look at the record and view the attachment array, I see values for Filename (taken from the URL), Id (a valid Airtable Id), and Url (the public URL to the file - link works fine). Size, Thumbnails and Type are all null. On a another file that works, the Size, Thumbnails and Type values are filled out and the Url is changed from what I submitted to a “” There are no error returned from the API call.

Our web server that hosts the files are IIS on an AWS instance. In reviewing the web server logs, I don’t see any request to the server for the “bad” files. For the “good” files I see a request from “Filestack” at the time the API record was created.

I have been trying to “resubmit” the empty file by taking the array of attachments in the record and removing the ID before submitting back to Airtable as an Update (effectively deleting the original attachment since the ID no longer exists in the array and then creating a new attachment). Sometimes this will work, sometimes it won’t. I can try a few times with it failing everytime and then go back a few hours later and it will work on the first try. (At all times the URL being passed is live and available on the internet).

3 Replies 3
5 - Automation Enthusiast
5 - Automation Enthusiast

I don’t have an answer for you, but I want to compliment you on your thorough and clear description of the problem and what you’ve tried. :slightly_smiling_face:

:slightly_smiling_face: Worked directly with Airtable support and they patched our Airtable to fix the issue.

4 - Data Explorer
4 - Data Explorer

If you don’t mind my asking - How does one get them to “patch” the Airtable?