Help

Hide record ID not working in form prefill.

Topic Labels: Formulas
Solved
Jump to Solution
481 3
cancel
Showing results for 
Search instead for 
Did you mean: 
Anxious
7 - App Architect
7 - App Architect

I am trying to follow this video tutorial: https://www.youtube.com/watch?v=BkAY7OHEgdc

The formula:

 

'https://airtable.com/shr12G6XKocbeGi0H'&'?prefill_Doll%20ID='&RECORD_ID()&'&prefill_Doll%20Name='&ENCODE_URL_COMPONENT({Doll Sculpt})&'hide_Doll%20ID=true'

 

However, the part to hide the record ID is not working. This is what happened to the form:

Anxious_0-1675714613846.png
As you can see, the "Doll Name" area has the formula to hide the record ID in it. 🤔

 

I tried doing it exactly like the video and only having "(Doll Sculpt)", but it said there was an error with the formula and I was forced to use "({Doll Sculpt})". Could this be the issue?

I haven't even tested the functionality (I haven't set up the automation) of this yet because I have hit the snag listed above. 😥

Thanks for reading!

Airtable Account: Free Plan
Records: 1,200/1,200 (I might have to find a different solution soon)
Automation Runs: ??/100
Extensions: 1/1 (TinyPNG Compression Script, looking for free alternatives)
This video shows you how to set up an Airtable base that will automatically email a list of contacts and collect their RSVP responses. It uses automations and prefilled form fields to do that. The original idea came from this video by John at @no-code , which shows how to use this method to create
1 Solution

Accepted Solutions
marks
Airtable Employee
Airtable Employee

Looks like you want to change

&'hide_Doll%20ID=true'

to

&'&hide_Doll%20ID=true'

The first & is for the Airtable formula to concatenate (combine) the components and the second & is to go into the URL

See Solution in Thread

3 Replies 3
marks
Airtable Employee
Airtable Employee

Looks like you want to change

&'hide_Doll%20ID=true'

to

&'&hide_Doll%20ID=true'

The first & is for the Airtable formula to concatenate (combine) the components and the second & is to go into the URL

Fantastic, that worked!

However, I tested this out with the automation and realized that it deleted the original table data if the relative update form field is left blank, which makes sense since it directly replaces all the data in that record. That won't work for me, so it is back to square one.

I could prefill ALL the data, but this is a massive table with photos and linked records, so that may not work.

Airtable Account: Free Plan
Records: 1,200/1,200 (I might have to find a different solution soon)
Automation Runs: ??/100
Extensions: 1/1 (TinyPNG Compression Script, looking for free alternatives)

Hey @Anxious - I'm glad that helped!

And yes, you're right. I am not 100% sure of the cleanest way to handle that in the UI (in the API, this is the difference between a PATCH and a PUT request). Off the top of my head, if you are adding these new records into a new table, you could have a formula that looks at the form submission versus the previous record (via linked records) and then return the original value if the form submission's value was left blank. This would not allow people to empty a field via the form submission without some special-case'd keyword like "empty" or something and then working that into your formula logic.

I'd recommend maybe starting a new thread on that topic to keep things clean and searchable in the forums!