Help

Re: IF formula always pulling in value, even if the condition is not met

Solved
Jump to Solution
993 1
cancel
Showing results for 
Search instead for 
Did you mean: 
Lauren_Briskin1
6 - Interface Innovator
6 - Interface Innovator

Hi!

I'm having such a basic issue and can't figure out what I'm missing. 

I believe this should be a very basic IF statement: IF {field} is not empty, show this stuff. However, I've tried using {field}, {field}!="" and {field}!=BLANK() and even where there is nothing in {field}, text is showing. 

Here's the simplified formula I'm using to figure out what is going on (substituting "the text" for what will really be there):

IF(
{abr formula- all},
"the text"
)
Here you can see that even if {abr formula- all} is blank, "the text" is showing up.
Screenshot 2023-02-16 at 10.12.13 AM.png
Any help appreciated!
1 Solution

Accepted Solutions
Lauren_Briskin1
6 - Interface Innovator
6 - Interface Innovator

Okay! I figured this out. I didn't need !=BLANK() or !="", just using IF({field}) is enough, BUT the field it was pulling in had line breaks in it, which i couldn't see in the output. So it was always showing something because there WAS something!

See Solution in Thread

6 Replies 6
Anna
6 - Interface Innovator
6 - Interface Innovator

Your formula as written is basically saying, if the {abr formula- all} field exists (which it does regardless of whether or not it's empty), return "the text".

I believe you want one of these two options:

IF({abr formula- all}=BLANK(),"","the text")
IF
(NOT({abr formula- all}=BLANK()),"the text","") #more complicated but can be useful in certain situations

Hmm.. I haven't had to do that in the past, and my understanding was that if you use IF and {field} it's actually checking for a value there? 

Lauren_Briskin1
6 - Interface Innovator
6 - Interface Innovator

Here's an example where it works as I've done it this wayScreenshot 2023-02-16 at 11.10.58 AM.pngScreenshot 2023-02-16 at 11.11.04 AM.png (with an extra AND)

 

Lauren_Briskin1
6 - Interface Innovator
6 - Interface Innovator


 
It also seems to work sometimes? Screenshot 2023-02-16 at 11.49.43 AM.png
IF(
{abr formula- all}!=BLANK(),
{abr formula- all}
)
 
But if I put "the text" in there, it always shows a value.

 

When you write IF({abr formula- all}!=BLANK(),{abr formula- all}), you're saying if the original field is not blank, infill the new field with the text from the original field. 

 
When you write IF({abr formula- all},"the text")you're saying if the original field exists, infill the new field with "the text". In this formula, you're not evaluating whether or not the original field is populated.
Lauren_Briskin1
6 - Interface Innovator
6 - Interface Innovator

Okay! I figured this out. I didn't need !=BLANK() or !="", just using IF({field}) is enough, BUT the field it was pulling in had line breaks in it, which i couldn't see in the output. So it was always showing something because there WAS something!