Help

Re: Setting Timezone without Time in Date Field

589 0
cancel
Showing results for 
Search instead for 
Did you mean: 
AnitaHallberg
5 - Automation Enthusiast
5 - Automation Enthusiast

Hello!

I'm having issues with Airtable's default GMT timezone. I have a Date field (which I do not want to have time displayed for) as well as a formula field using the DATEADD formula to calculate the next time a task is due, based on frequency. 

In the formula field, I can specify timezone. In the Date field, I can't - without adding the time. Because of that, it's calculating incorrectly - everything is off by a day. Only when I add a time do the dates show up correctly. 

Is there any way to fix this? Do I need to add something to my DATEADD formula? 

Thank you!

Screenshot 2023-02-20 at 2.10.04 PM.png

 Screenshot 2023-02-20 at 2.07.35 PM.png

4 Replies 4

Date only fields are always midnight GMT when used in formulas. Since your formula result is a date, set the formatting tabl of the formula field to use the same Timezone for everyone (GMT). 

Thank you for your response! Is there any way to make them both appear in EST?

lailah
4 - Data Explorer
4 - Data Explorer

I would also like to know how to set the time zone on a date field without displaying the time. Why is the "Use the same time zone for all collaborators" option not available without the time being displayed? Is there a way to enable it?

I would also like to know this. It's very frustrating!