Help

Upcoming database upgrades. to improve our reliability at 03:30 UTC on Feb. 25 / 7:30pm PT on Feb. 24. Some users may briefly experience slow load times or error messages. Learn more here

Simple IF Statement not working. Help

Topic Labels: Formulas
447 2
cancel
Showing results for 
Search instead for 
Did you mean: 

Trying to workaround the fact that can’t do both OR and AND filters by using an IF statement. This is just the beginning but I can’t get it to throw the correct result. Suspicious it is because it doesn’t work for Fields that are linked to other tables, but not sure why it wouldn’t. Am I missing something else? Perhaps because it is a string? It seems like a really easy IF statement, but it throws “No” when it should throw “reponsible”). Help!Screen Shot 2021-02-01 at 3.25.55 PM

If this can’t be fixed perhaps you have other ideas for how I can show only those entries for which a specific entity is either responsible or accountable (ideally with the ability to group by which they are)/

2 Replies 2

Hi @Rebecca_Niles - your formula should work - maybe there’s an additional character in the linked field that isn’t in the formula?

I did a similar thing here:

Screenshot 2021-02-01 at 20.39.56

The two formulas both work with a single linked field.

Formula 1 is:

IF(Person = 'Jim', 'Yes', 'No')

Formula 2 is:

IF(FIND('Jim', Person), 'Yes', 'No')

The difference is that Formula 2 will work if more than one record is linked:

Screenshot 2021-02-01 at 20.41.35

Yes. So simple. I should have figured that out. Had removed the space BETWEEN the words but not checked for an errant space after. Thank you!!! Thought I was going crazy.