Help

API key to PAT (late to the deprecation party and need help!)๐Ÿ˜…

Topic Labels: Integrations
157 0
cancel
Showing results forย 
Search instead forย 
Did you mean:ย 
Carson_Carr
4 - Data Explorer
4 - Data Explorer

I just saw the final deprecation email a few days ago (my work email has so much junk I rarely check it unless I already have a thread going). I'm trying to update a touch screen experience I built 2 years ago. This is the first and only project connecting an app I made in unreal to airtable so hopefully I'm just rusty and it's an easy fix.

I'm able to see the records using web.postman.co so I know the personal auth token is working, but retrieving and sorting them in unreal (using the VA rest plugin) is more complex.

here's a comparison of the old API key method VS one of many things I've tried so far for the API call. they're identical except for the third line.
01_airtable_PAT_compare.png
I also tried removing the 2nd line with the sorting but that's not working either. like this-
https://api.airtable.com/v0/appWrAePyRvMx3CVf/tblZxE2HTTGaYbVEl
-H "Authorization: Bearer pat##############etc

here's one of the unreal engine blueprints. this populates one of many pages in the app where I'm getting many images from airtable, building an array, then setting image containers with them.
02_API_call_nodes.png

this is what's inside the image grabber function. I haven't changed anything here from the working version but it should help show what I'm doing with the request.
03_UE_img_grabber_function copy.png

and here's the PAT working in postman... if anyone can point out what I'm missing, I'd really appreciate it and thanks for reading this far! 
04_postman.png

0 Replies 0