Re: Calendar color field not showing up

1623 0
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

I have a table with a lookup from another table in a grid view in which the result is Brown. When I go to the calendar view to select the field for the color, it’s not in the list of options.
Screen Shot 2022-05-10 at 9.55.17 AM
Screen Shot 2022-05-10 at 9.55.51 AM
Thank you!

6 Replies 6

Yeah, Airtable’s lookup fields will convert your single-select field to an array, so you’ll have to manually create all of your coloring criteria from scratch.

You may want to bring up this issue to, so hopefully they can improve this behavior in the future.

6 - Interface Innovator
6 - Interface Innovator

As @ScottWorld said, there’s no default way to do this.

However, there is a workaround that, while a little clunky, definitely will accomplish what you’re looking for. It requires setting up an automation that watches for when a record is linked, and then copies the linked color to a single-select field in the same table as the desired calendar view.

Here’s a quick walkthrough I recorded on setting this up for your base.

Hope this is helpful,

6 - Interface Innovator
6 - Interface Innovator

Hi Paul
Thank you so much for taking your time to make the video. I am new to AT but I will give it a try tonight.

This is a fantastic workaround! Sorry I didn’t mention this earlier, @Russ_Keitel!

Oh no problem. I just appreciate the the incredible support from the people here