Help

Can't copy/paste record from one table to another

Topic Labels: Data
833 2
cancel
Showing results for 
Search instead for 
Did you mean: 
dk1
4 - Data Explorer
4 - Data Explorer

Hi all,
I am running into an issue with a new table I have created in my primary base.

I want to copy a single record from Table 1 to Table 3 and the record has 15 fields.
When I copy the record from Table 1, it says '15 cells copied'.

When I paste the record in Table 3, I get a dialogue box saying "Do you want to expand this table?
To fit your pasted data into the table, we need to add 11 more fields."

When I select 'Expand the table so that all of the pasted cells will fit.' then click continue, nothing happens.
Nothing gets pasted, no fields are created, nothing.

I tried clearing cache, doing this on the app rather than the website, deleting the table and creating a new one, using other records and nothing is working. Is this a known bug?

I created a blank table with 15 fields and that allowed me to copy the single record in, but when I tried to copy multiple records and it had to expand the table by adding more rows, I experienced the bug again. The bug seems to happen when the 'Do you want to expand' dialogue box is triggered.

For now, I need to create a blank record for every record I want to copy over, which is quite an annoying waste of time.

I've attached a screenshot of the fields and the record I've been testing with.

2 Replies 2
ScottWorld
18 - Pluto
18 - Pluto

Copying and pasting is currently broken in Airtable. I have no idea if or when they are planning on fixing it, so everybody should email support@airtable.com about this major problem.

siriwat
6 - Interface Innovator
6 - Interface Innovator

It's a bug on Airtable side.

Workaround for the moment is, you have to precreate enough rows before pasting your data.

See 👉 Pasting data with row expansion not works! - Airtable Community