Can’t push data with Integromat into Single Select columns anymore

Topic Labels: Integrations
5970 6
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

Hi there!

I use Integromat (thank you @Julian_Kirkness !) to feed my Airtable.
But since last week, some of my automations fail because it can’t push data into columns of type « single select ». I’ve tried many things (change the column type to multi, store the options in the column before Integromat plays, change the column type to short text), the scenario fails again & again.
The input data comes from a cell in a multi select column, my goal is to take each options to create separate records in another Airtable (that’s why I use Integromat over Zapier here).

Is anyone experiencing something similar? Or was and found a fix to it?
I can’t found what I’ve done wrong here…


6 Replies 6

Hi Jeremy

I just set up a quick test pulling a value from a google sheet to an Airtable table - with one text field and one Single Select and it worked fine (as long as the value for the Single Select field is set up as an option in the field’s definition):

Screenshot 2019-02-12 at 09.42.27.png

I think what you’re saying is that in the past, adding a value NOT already in the field options would add the option (as it does if you paste data into the field)?

In which case I can concur that this requires valid values.

I can see value in both approaches (allowing or not allowing invalid values) - would be nice to have as an option in Integromat. I wish Airtable and Integromat would get their act together and sort out their interface properly - Airtable really needs this tool!

6 - Interface Innovator
6 - Interface Innovator

Hi @Julian_Kirkness and thanks once again for your time.

I’ll try again but I don’t know what’s really happening underneath the hood, it’s unclear.

The error I keep getting is “Validation failed for 1 parameter(s). Prohibited value in parameter ‘<column_name>’.”

What’s weird with this error is that sometimes, the first value pass. Every values are stored the same way in the options of my Airtable single select columns (I copy & paste them to avoid any typo). To me, there’s a catch with the loop but I can’t figure out why the parameters can be sometimes (it’s completely random to me) good enough to pass a value and then not.


There’s a new version of Google Sheets (v2) that was just put out by Integromat, last week. There have been some issues with scenarios that are using GS v1. I don’t know if this might have anything to do with it or not. I don’t want to confuse things, but I thought I would let you know.


6 - Interface Innovator
6 - Interface Innovator

Hi @M_k, thanks for this info.

It’s no secret that Integromat and Airtable doesn’t work well together. The making of a scenario in which Airtable is involved often leads to error message such as “Failed to load data”. The guys behind Integromat are trying to find a solution with Airtable and I hope they will soon reach an agreement regarding the access of Airtable’s API.

But for this issue, what’s weird is that suddenly, everything stopped working. I’m looking how can I implement a similar scenario with Zapier, I need high reliability here.

Hi @Jeremy_Brunet

Did you manage to figure out what’s happening with your issue? I would be interested to know, since it seems I am having similar issues.

Thank you,

Hi @M_k

Integromat came back to me, they thought it was because the options were case-sensitive and it’s true that some capitalized letters were missing.

After fixing it, nothing worked better.

Let me describe step by step the whole thing:

  1. I use Zapier to push data from a Copper opportunity (Copper is a CRM) into an Airtable sheet. In this sheet, there’s a multiselect column where I store all the products & services I’ve sold to a customer. I didn’t store any options in Airtable beforehand and everything works fine.

  2. Once I have this collection of products & services stored in this multiselect column, I’d like to feed another Airtable sheet where each line will be one product. Imagine I’ve sold three products to one customer, I’d like to create three lines for each of them. The column where I will read the name of the service or product sold is a single select column. To do so, I use Integromat and their handy iterator module.

  3. In another table, I’d like to the same as step 2 except that I’d like to repeat this process multiple times. Imagine I’ve sold three services to one customer that I’ve committed to deliver every month, I’d like to create three lines for each of them x the number of months during the deal runs. The column where I will read the name of the service is a single select column. It’s my long-term preview and here again, I use Integromat and their handy iterator & repeater modules.

Everything worked fine and not only once until earlier this month.

Here I’m trying to fix the third step as it’s the most complicated.
What I see is that the first service sold is correctly reported in Airtable, Integromat does create the right number of lines and push correctly every single information. Then when the second loop starts, it crashes immediately, reporting that the parameters of the single select column are invalid.

Integromat quotes what are the valid values expected when you set up the scenario and turn on the mapping option. Even after copying and pasting these values, the parameters aren’t valid.

So to my understanding, Integromat is throwing the wrong error. Now, I’m trying to figure out why only the first loop works, that’s my best lead.

I’ve tried to get rid off the single select column and change it to a classic short text type of column, it didn’t fix my issue. This test tends to confirm my guess that the parameters have nothing to do in this story, there’s an error somewhere else.

One last thing: I’ve contacted Airtable support to see if anything regarding the single and multiple select columns has been changed or subject to a recent update, they told me no. If there’s a technical dysfunction somewhere, it’s probably on Integromat’s side.