Help

Re: Can't use a date calculated by Formula Field in Calendar View [SOLVED]

Solved
Jump to Solution
3176 1
cancel
Showing results for 
Search instead for 
Did you mean: 
Y_K
7 - App Architect
7 - App Architect

I calculate a member’s upcoming birthday by using formula.

IF({birthday} = “”, “”,DATETIME_FORMAT(DATEADD({birthday}, DATETIME_DIFF(TODAY(), {birthday}, ‘years’) + 1, ‘year’), “YYYY-MM-DD”))

So if someone’s birthday is 1980-05-20, the field will show 2017-05-20. I want to show this in a calendar view. However it does not allow a Formula field (only allows static Date field). Is there a way to set the calculated field to have date-time format?

14 Replies 14
David_Earley
5 - Automation Enthusiast
5 - Automation Enthusiast

Using the formula in the Calender is working but the Times all translate to 12:00. This is the formula I am using.
Trying to shift the time to GMT so I can export to Google Calendar and have the times right.

 IF({Taping Date Time (CT)} = "", BLANK(), DATEADD({Taping Date Time (CT)}, -6, 'hour'))

Even Setting it to a timestamp field dose not work.

{Taping Date Time (CT)}

[Solved] Just figured out I needed to change the field format to not 12 hour.

David,

Will you explain how you solved the 12:00am issue in a little more detail? I’m so close to figuring it out but I just can’t quite get there.

Edit: Never mind, I just figured it out! See, I knew I was close.

Marissa_Blahnik
4 - Data Explorer
4 - Data Explorer

I’m using the DATEADD formula to create a new field for date and it is populating a calendar successfully, however it includes the 12:00a timestamp.

My formula currently is: IF({Publish Date},DATEADD({Publish Date},-7,‘days’))

When I add DATETIME_FORMAT to remove the timestamp, it no longer will populate the calendar AND it removes my IF({Publish Date} and returns errors on dates with no publish date.

DATETIME_FORMAT(IF({Publish Date},DATEADD({Publish Date},-7,‘days’)), ‘MM/DD/YYYY’)

Can anyone tell me what I am doing wrong?

Thank you!

Add BLANK() to your IF statement.
IF({Publish Date},DATEADD({Publish Date},-7,‘days’), BLANK())

Same problem, any solution to this?