Help

Date format

Topic Labels: Data
1512 11
cancel
Showing results for 
Search instead for 
Did you mean: 
SidStunt
5 - Automation Enthusiast
5 - Automation Enthusiast

Dear community,

All the data in my database is formatted as DD/MM/YYYY. 

This question is about meetings we have. The meetings should be link to other records. But when I want to link the meeting with date format DD/MM/YYYY in another table, the format is MM/DD/YYYY, which is quite confusing. Any idea how I could solve this?

There is a screenshot of the situation attached. 

11 Replies 11
Sara
8 - Airtable Astronomer
8 - Airtable Astronomer

Hi, you can change the format of the date on airtable in this way:

 

Sara_0-1699882364517.png

 

Let me know if you have any other question 🙂

 

SidStunt
5 - Automation Enthusiast
5 - Automation Enthusiast

Hi Sara! Thank you.

I know that's where you can change the format. But the format in the database is right! In every column it's DD-MM-YYYY. But when I link the table to another, the format gets changed into MM/DD/YYYY. Which you can see in the screenshot I attached... This seems to be a bug right?

Sara
8 - Airtable Astronomer
8 - Airtable Astronomer

Have you changed the formatting in the linked column too? 

Sara_0-1699968468324.png

because you have problem with the form's formatting, even if the column is a link field, you should change the formatting to European. Airtable automatically select the US format.

Sara_1-1699968589991.pngSara_2-1699968625352.png

this should solve your problem. Let me know if this solve your problem 🙂

 

SidStunt
5 - Automation Enthusiast
5 - Automation Enthusiast

First of all, Thanks for diving into it with me.

The formatting in the linked column was already on Local DD-MM-YYYY. That's the formatting i wish for and what I set it on throughout our database. But suddenly when I link the record it just changes it to MM/DD/YYYY in the other table.

So here you see the database which I link to another table.
Schermopname (6).png

 

And here you see the link to the records above, but then the data format suddenly changed:

Schermopname (7).png

 

Thanks again! Would be great to have this solved:)

Sara
8 - Airtable Astronomer
8 - Airtable Astronomer

Hi, have you changed the formatting of "Link voortgangsgesp.."? . If you edit that column, you will see directly the "configuration" tab, but there is also a "formatting" section

 

as here:

Sara_0-1700053624590.png

 

SidStunt
5 - Automation Enthusiast
5 - Automation Enthusiast

Yeah I tried, but there doesn't seem to be a formatting option in the linked record. 

Schermopname (8).png

And below you find the settings from the table where the linked record 'belongs'

Schermopname (9).png

Sara
8 - Airtable Astronomer
8 - Airtable Astronomer

Okay, got it, you just use the link field, you need to create a new column with a "Lookup" field

 

Sara_0-1700056570526.png

and where I wrote "Table1, you have to write "Link voortgangsgesp.." and where I wrote "Date", you have to select the column on your primary table " Datum gesprekken", and after you have to change the formatting. 

 

SidStunt
5 - Automation Enthusiast
5 - Automation Enthusiast

Thanks. That solution does work a bit when I just show the value somewhere in a table.

However, I do need to link a 'Voortgangsgesprek' to 'Stunt vaardigheden'. We do that when we fill out a form. 

Schermopname (12).pngSchermopname (13).png

As you can imagine it's quite confusing for users who always use DD-MM-YYYY. Thereby, we do have multiple conversations at one time, but it does need to be linked to the right one. More information in there, like there is in the table And the right date format, would be great. 

Schermopname (14).png

Sistema_Aotearo
7 - App Architect
7 - App Architect

Oh this does seem weird and strange behaviour. Not sure if this will work, but you can try either:

1. Use a formula to derive the the date in your first field. Possibly:

DATETIME_FORMAT(

  SET_TIMEZONE(

    {Date Field}, 'Europe/Amsterdam'),

  'DD/MM/YYYY'

)

 

2. If that doesn't work, it may be a glitch in the form builder. Try using the new form builder in the interface designer. I think there also may be an option in your form to convert your form to the new forms?

SidStunt
5 - Automation Enthusiast
5 - Automation Enthusiast

Thanks. However I cant change the primary field in the table, since it's embedded in so many places in our interface. Users need to be able to change and add the datafield there, which will not be possible if it's a formula field. I could then let them use another data-pick field, but the primary field is always visible as well, which is not desirable.

It doesn't seem to be in the form builder. Because when I look in the table where the form is in, the table view also shows me the wrong format. See below.

Could you report this as a bug? Seems to be the case at least

Schermopname (15).png 

apianka
4 - Data Explorer
4 - Data Explorer

I'm having the same problem, would be interested in a solution as well, as it's quite annoying for everyone working with the DB..