Help

Format Date to Use in Link Field

3529 19
cancel
Showing results for 
Search instead for 
Did you mean: 
Jason_F
6 - Interface Innovator
6 - Interface Innovator

I am having major problems all of the sudden with a link field automation that uses a date.

Let me start by saying if I copy and paste my date from one table into the link field it works fine.

If I try to do it via. Automation I keep getting an error that says this field can not accept that input.

Seems to be a recent problem. Any help? This is breaking a ton of stuff for me.

19 Replies 19

If the automation is pulling directly from a date field, that could explain the problem. My gut says that Airtable is complaining about inserting the underlying datetime data into the link field, but when copying and pasting manually there’s an automatic conversion to text that’s happening in the pasting process.

The quickest way that I can think of to solve this is to make a formula field that formats the date as you wish, then tweak the automation to copy that formatted date into the link field, which should work without errors.

Jason_F
6 - Interface Innovator
6 - Interface Innovator

How do I format it as m/d/yyyy I’ve tried that and it still fails.

I tried to replicate this issue as I understand it (well or not) and got the same failure. Doesn’t a link field expect an array (whether it’s a single or multiple)? Does the copy/paste automatically cast the pasted value(s) to an array format whereas the automation doesn’t?

I don’t know but am curious.

This is so frustrating for multiple reasons.

  1. It was working last week 100%
  2. I have tried Turing it into an array and automating and I get the error.
  3. I have tried turning the array into a string by concatenating it with a blank element.
  4. If this is an issue then Airtable should not allow you to use Date field as the first column or let me designate another item as the primary column without screwing up all the rest of my tables that link to it.

When setting the link options via JavaScript, it does. Specifically, it must be an array of objects pointing to specific record IDs. I haven’t tried to set links via an automation that often, but the few times that I have, I’ve used a record ID, so maybe they’ve begun enforcing that method across the board.

@Jason_F If it was working before and has only recently begun failing (I believe you said this in your original post, but I somehow glossed over that point), I recommend contacting Airtable support directly.

Jason_F
6 - Interface Innovator
6 - Interface Innovator

Thanks Justin.

I can’t use the record ID because it doesn’t know what that is yet.

The date or value is what will link the record as that’s the known fact.

I would contact Airtable support as well. However, would it be possible to add another action in your automation that creates the record in the second table, assigns the date from the current table to the primary field, then uses the record id for that newly created record in a following update record action that assigns the created record id to the link field?

Not sure as I’ve never tried. Let us know how it works out.

It will not even accept the record ID at this point. I have no updated it so it brings in the date once but will not accept it back in another field.

That’s very odd. Could you share a screenshot of how you’re setting this up to pass the record ID?