Help

Re: Google calendar on phone not syncing with shared calendar

Solved
Jump to Solution
23928 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Nicole_Hillborn
5 - Automation Enthusiast
5 - Automation Enthusiast

I have synced my calendar (using sync to an external calendar option under share view) to my google calendar on my laptop. I see the events from that calendar there. On my phone, I have set up to see google calendars. When I look at a date that I know there is an event for, I do not see it. Any ideas as to why I would see it on the desktop calendar, but not on my phone?

1 Solution

Accepted Solutions
Nicole_Hillborn
5 - Automation Enthusiast
5 - Automation Enthusiast

 

RESOLVED: From google's help:
Sync other calendars
  1. On your computer, visit the Calendar sync page.
  2. Check or uncheck the names of any calendars.
  3. In the bottom right corner, click Save.
  4. When you're done, refresh your calendar.

I checked my calendar on my phone and all the events are there.

See Solution in Thread

6 Replies 6
ScottWorld
18 - Pluto
18 - Pluto

Unfortunately, Google Calendar only refreshes external calendar subscriptions once every 12-24 hours, and there is no way to increase the frequency.

Your only 2 real options are:

(1j to use a different calendar app that refreshes external calendar subscriptions more frequently, or

(2) manually create your own synchronization process between Airtable and Google Calendar. This would be a bit of work to setup, but you could do it in a very limited way with Airtable’s native automations (Airtable gives partial instructions here), or in a much more advanced/complete way with Make.

There can be a bit of a learning curve with Make, which is why I created this basic navigation video for Make, along with providing the link to Make’s free training courses. There are also many Make experts hanging out there who can answer other Make questions.

p.s. If you have a budget for your project and you’d like to hire an expert Airtable consultant to help you create this, please feel free to contact me through my website: Airtable consulting — ScottWorld 

Nicole_Hillborn
5 - Automation Enthusiast
5 - Automation Enthusiast

 

RESOLVED: From google's help:
Sync other calendars
  1. On your computer, visit the Calendar sync page.
  2. Check or uncheck the names of any calendars.
  3. In the bottom right corner, click Save.
  4. When you're done, refresh your calendar.

I checked my calendar on my phone and all the events are there.

Yes, but if you add a new event in Airtable, does Google update on its own in real time?

Scott, I'm assuming the 12-24 hrs thing will still be an issue, which is fine,  My issue was that none of the items were appearing on my phone and I had waited 48 hrs.   Once I selected the calendar on the calendar sync page, the events appeared on the calendar on my phone.

Ah, got it. That’s great news!

This solved it for me! In case anyone needs it, here's the URL for google calendar sync. I'm not sure how to find it through Google Calendar, so I found the link via search: https://calendar.google.com/calendar/u/0/syncselect