Help

How to add photos in bulk to a table?

Topic Labels: Views
18703 11
cancel
Showing results for 
Search instead for 
Did you mean: 
David_Laufer
6 - Interface Innovator
6 - Interface Innovator

I’m new to Airtable, probably this is super basic, but… How to add photos in bulk to a table, so that each one becomes a separate record? I have a file of 100 photos, and I want to bring them into my base so that each one is a separate record that I can then add keywords and text to describe it. Thanks!

11 Replies 11

You can’t within Airtable, but you can do it with Zapier or Integromat:

Actually, you can in Airtable.

In the table you want to add these photos to, create a “Gallery” view.

Then select all of your photos and drag-and-drop them onto the gallery view – you will be asked if you want to create a new record for each photo, or one record for all the photos.

Oh! I didn’t know that. Cool! :metal:

Jeremy - you are brilliant! worked like a charm! Thanks a ton. :surfing_man:

Jeremy- have you run across anyone in the AirTable community who can advise me on the structure of a complex base? see my post today for a bit more detail. Thanks!

I’m reading it now, @David_Laufer. :slightly_smiling_face:

Hi Jeremy,

If you are still being kind to noobs; for the life of me I can’t get this to work - if I bulk select, drag or copy images in the Gallery view they all get added to a single record as I don’t appear to be given the option to add them as individual records.

Is there a very obvious step I’m missing…?

Yours hopefully.

Gwil

:thinking: … you’re certain it’s a “Gallery” view you are on, and not a “Grid” view? It has records shown as “cards” rather than as “rows”?

If so, I can’t think of any obvious reason why it wouldn’t be working.

Try:

  • dropping them directly on the “+” button to ensure you aren’t accidentally dropping them on a single record
  • using a different browser
  • disabling any pop up blockers or extensions you have running in your browser
Gwilym_Lewis
4 - Data Explorer
4 - Data Explorer

Hi Jeremy,

You are brilliant! What I was doing wrong was letting the red + button open an upload window and I was then trying to upload files rather than dropping the files directly on to it.

Thank you so much!

Gwil