Re: Importing from excel, CSV or Google Sheets - pop up does not appear

657 0
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Newbie here. I’m trying to import from excel and when i select the quick import option and select excel the pop up box does not appear. Screen flashes “loading” quickly but the pop up does not appear. I get the same issue with CSV, Google sheets, and other import options.

I’ve already updated pop up options (using Chrome) to ensure they’re allowed. I can’t see any other topics on this issue. Not a great start to my airtable experience.

2 Replies 2

Hi Nick, that’s strange. I’ve never had any issues with that and it also worked just now. So I think this is still a browser issue on your end. Have you tried using a different browser? Also this is not a pop up in the traditional sense (completely separate url loading), but what is opening here is an integral part of the Airtable web app.

Works for me, too, so it must be something with your browser.