Help

Quoted Field is Malformed

6429 7
cancel
Showing results for 
Search instead for 
Did you mean: 
Education_Depar
4 - Data Explorer
4 - Data Explorer

I am trying to do the CSV Block import and I keep getting this error: “Trailing quote on quoted field is malformed.” I don’t have any " " in the data set. Any suggestions for what I might be missing?

7 Replies 7

Just checking in to see if you ever found a solution to this issue, or if it’s still giving you problems. I don’t see any replies, and want to make sure your issue doesn’t go un-resolved.

I’ve run into occasional weird issues like this when trying to import a data set that contained non-alpha characters. In my case, the data — furnished by a client — imported correctly, but any attempts to search the resulting base or perform comparisons failed miserably. Even worse, when opened in any of the suite of word processors, text editors, and spreadsheets I typically keep on hand, the offending values were stripped out or rendered invisible. It wasn’t until I opened the file using a hexeditor — and at this point I don’t recall which one; irritatingly, the software download folder from that particular machine didn’t make the cross-country trip — that I could determine which lines from the CSV were corrupted.

If you haven’t been able to find a solution, I’d suggest finding a freeware hex editor and examining the source file. Look especially for embedded ASCII 0x0a, 0x0b, 0x0c, or 0x0d values, which might be signalling end-of-line to Airtable’s parser.


Edit: In looking back through old posts, I see from this the hex editor I used must have been Frhed.

Jason_Ennis
4 - Data Explorer
4 - Data Explorer

Thank you for this info. I was having the same issue and was able to use the web based hex editor to find the issue with my file. https://hexed.it

Thanks for the info and link – looks like a great site to have on-hand — especially when called upon to troubleshoot from someone else’s PC!

Gaspar_Caro
5 - Automation Enthusiast
5 - Automation Enthusiast

Hi, did @Education_Department resolve the original issue? I’m at too basic a level to use the hex editor solution provided by @W_Vann_Hall and @Jason_Ennis so am hopeful that you found an alternative!

ADAM_COREA
4 - Data Explorer
4 - Data Explorer

I have just encountered this issue. Tried 3 times to upload but same error. I tried this though and it worked!

Go into the .csv file and sort it by another field column (so for instance, my data was in Post Code order but I re-sorted it by Organisation Name order, you could just sort it by any alternative column).

It loaded without issue once I did this.

Kate_Price
6 - Interface Innovator
6 - Interface Innovator

I’ve run into this issue a few times myself recently. I’ve been able to resolve it by copying and pasting the data into a new spreadsheet. I paste the values only (with no formatting) and reapply any necessary formats. This seems to fix the issue for me.