Sort fields by type which not empty

581 7
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Hi everyone,

I have an automation where all field become empty everyday. So far it's ok. I made a sort by last modification to find the next day all last changes.

I try now to sort (please find the attachement) by type (Légume or fruit) when the total >0 but i can't find the solution. When i sort by type, i have all the type first even the articles with total=0 and i don't know how to make it. 
I tried to group my table by type or multiple sort but i have the same issues.

I want to have by type all products wich are not total=0 and sorted by type (fruit or légume)

Thank you so much for your help 🙂

7 Replies 7

Hello @BassemB! Can you please share a screenshot of your Sort conditions?

And can you clarify how you want your sort to appear? Do you want the records to sort by total based on the type?

For example:

  1. Legume = 4
  2. Legume = 2
  3. Fruit = 3
  4. Fruit = 1

Hey it's exactly your example

Name - Type - Total
Abricot - Fruit - 3
Ananas - Fruit - 2
Raison - Fruit - 0
XX - Fruit - 0
Concombre - Légume - 4
Pomme de terre - Légume - 1
xx- Légume - 0

i would like to sort by type (I don't car if it's légume or fruit) and by total >0.

The result would be (if we choose the sort by type a-z , fruit first) :
Abricot - Fruit - 3
Ananas - Fruit - 2
Concombre - Légume - 4
Pomme de terre - Légume - 1
Raison - Fruit - 0
XX - Fruit - 0
xx- Légume - 0

Thanks for clarifying! Records are sorted in order of the Sort conditions so you'd want to first sort by Type and then sort by Total. Lastly, make sure "Automatically sort records" button is toggled on.

See example screenshot attached.



Hi @AirBenderMarcus 

unfortunately it's not what i want. I saw this display but i will have hundreds of lines and i don't want to see lines where the total is 0.
In your example Abricot and kiwi (with total at 0) have to be below of Gingembre an Concombre.

Do you understand ?

Thanks for your reply

Ah yes I understand. What you want to do is add a filter.

Sort options just change the order of the records, but filters dictate which records actually appear.

Add a filter where Total > 0 and that will hide all the 0s



Hey 🙂

It's close but i need to display the rest of record for the team so that they can fill the airtable the next day.

I already find your way but it's not ok unfortunately.



Could you just make a personal view with the sorts and filters the way you want? Then the rest of your team can use other views that show the records they need.