(Rare bug) Attachment may exist in table with "undefined" size, can be opened and previewed as usual, but missing "download" button, and link is not working

558 0
Showing results for 
Search instead for 
Did you mean: 


tried to script “show size of all attachments in all base”, and after debugging with “check null”, “check empty array”…“check array of nulls” still get unexpected result.
Investigation discovered rare bug ( I checked several huge tables with tens thousands of attachments, and that’s just in one record)

Annotation 2021-12-15 212147

I suppose it’s an interupted upload result, but I surprised it exists there. Can’t be downloaded, guided to other storage. Link is not working.

Annotation 2021-12-16 024052

No problem, just to inform.
I discovered that script is useless. Airtable detects similar docs and store once, with linking the same. Btw, it’s an answer to @itoldusoandso post

I’m gonna to rewrite my script using Map data type, with url as key, so it will display correct total size. Sadly, it can’t use recursion used in “sum” function
In case someone interested, i can put the source here.

0 Replies 0