Automation Giving Error "Could not find matching rows for string" and also not pulling all fields specified

Hello! I have an automation setup that when run “successfully” only populates some of the fields specified in the the action. Screenshot included below and highlighted where the errors are occurring. I also after a successful run initially eventually got an error message (seen in a screenshot below that “Could not find matching rows for string”. Was hoping could get some seeds of support on these two issues.

Results of Automation From Initial “Successful” Run (The column Tags__ForLinking is the target field that updates as a result of the automation):

Automation Setup:

Trigger:

Action:
(1) Properties


(2) Configuration

(3) Testing

Having a similar issue, same error message.

1 Like

Having same issue, unclear what’s cause of error.

Solved… I think this error is a result of the “Generate a preview” functionality. When a latter step is being tested that relies on a value from a previous step that was ALSO only tested in “Generate a preview” option, it throws the error because there’s no actual data to pull from. The solution is to “Run as Configured” the preceding step for which the affected test is pulling a data value from.

It would be nice if the “Generate a preview” used data from previous “Generate a preview” values, but doesn’t look like that’s the case…

1 Like

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.