Why does my time filed assume I'm entering a number of seconds?

Hi, I have a column that uses the “duration” field type. I have chosen to display the time as “h:mm”. However, when I type three digits (example “245”), I expect to see 2:45. Instead the table assumes I’m entering a total number of seconds, and turns the number into 4:05.

Can I tell Air Table to use the numbers I type and just put two digits after the colon?

If you type the colon while typing your numbers, then Airtable will behave the way you want.

If you just type numbers, no colon, Airtable assumes it is a number of seconds because that’s how it holds a duration value in the background (you can test this by making a formula field that returns the value of a duration field – it will always be returned as a number of seconds by default).

But if you type in the semi-colon or otherwise match the formatting of the field exactly as you have it defined (in this case, “h:mm”), then it will interpret your input as matching the format and enter it as you typed it.

Thanks for your reply. That’s what I have discovered - though it’s helpful to know that it relates to the duration value. The question however is: is this a setting I can change, or control with coding, or do I have to type the colon each time. (Actually, so far I’ve been doing pretty well at estimating the number of seconds…)

There are no settings to control how Airtable processes entries into Duration fields. You’ll have to type the colon each time. However, if you have no minutes to enter, you can leave that part off, and it will assume zero. For example, for 2 hours, just enter “2:” then hit Enter, and it will fill as “2:00”. Or if there are no hours, only minutes, begin with the colon; e.g. “:30” becomes “0:30” after you hit Enter. It saves a couple keystrokes at least.

Okay, thanks for your help.