Re: Duplicate Record Automation Failing

518 0
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

Hi there.

I use (or used) an automation via a check box to create a duplicate quote record when e.g. the client wants to make amendments to the line items of a quote and I want to keep the existing quote.

The duplicate record automation replicates a few fields from the previous quote and copies them to the new quote record as per the image below:

duplicate record

The problem I’m having is that the Line Items table’s primary field is a formula field so it looks like the automation doesn’t like it and spits out the following error:

“Field “Name” cannot accept the provided value: Cannot modify a computed field.”

This automation has actually worked before so I’ve no idea why it’s not working now or something has changed somehow.

Is their any way to resolve this or shall I just forget the idea of being able to duplicate this record within the structure of my base?


1 Reply 1
4 - Data Explorer
4 - Data Explorer

I just encountered – AND SOLVED! – this exact same error with an automation that is designed to update a related record after a form is submitted.

Like the example above, my form also includes a field that links to other records.

My testing confirmed that the error only occurs when the form includes more than one selection for the linked records.

I was able to solve the problem by configuring the token to display the ID, rather than the Name, of the linked records.