Help

Generic error on automation to update linked records across tables

Topic Labels: Automations
261 1
cancel
Showing results for 
Search instead for 
Did you mean: 
KyleC
5 - Automation Enthusiast
5 - Automation Enthusiast

My data schema is such that I have Programs which contain projects, each has its own table. I then have workers as a separate table, where I can link the workers to programs and/or projects.

 

I am trying to set up an automation that checks if a worker is linked to a program, and if so, automatically links them to the projects which are part of the master programs.

I've seen a few other questions similar to mine that seem unresolved... so not sure if this can even be done.

Trigger: when record matches condition

table: Workers

condition: when 'linked program' is not empty

 

Action 1:

in table "projects", find projects where linked program is record ID of program identified in the trigger (this seems to work)

Action 2: Update record in projects table

Record ID: make new list of "project name" from find projects (action 1)

Fields: Workers - add worker name...

 

It just says 'received invalid inputs'. worker name is the key field in the workers tab, and is computed from first + last name. project name is the key field in my projects tab, and is also computed... could this be the issue?

 

 

 

 

1 Reply 1
KyleC
5 - Automation Enthusiast
5 - Automation Enthusiast

 so with some more digging, it appears this is a huge error with how AT handles find records... and there is no way around it. what a crying shame that this has gone unaddressed for years.