Re: Problem with automation: attachment url is disallowed

5021 4
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

Hello everybody, i have a problem with an automation, it worked for more than a year without problems, but now it stopped to working giving me this error: attachment url is disallowed. I specify that nothing has been changed in the trigger, nor in the file to be attached (it is the same pdf format), the trigger starts when it finds the conditions inserted (and this passes) but when the email is sent it fails. Can you help me solve? Thank you

20 Replies 20
18 - Pluto
18 - Pluto

You can no longer refer to formula fields for attachment URLs. You will need to pull the expiring URL from the attachment field itself, not a formula field.

Some information on this is located here:

This can be done with Airtable’s native automations, with scripting, or with using an external automation tool like Make’s advanced automations & integrations for Airtable. Airtable’s article above mentions using Zapier, but I do not recommend using Zapier.

Make is significantly cheaper than Zapier, yet it is infinitely more powerful and customizable than Zapier. I’ve written an entire post here about Make vs. Zapier

There is a small learning curve with Make, which is why I created this basic navigation video to help. I also provide the links to a few other Make training resources.

p.s. If you have a budget for your project and you’d like to hire an expert Airtable consultant to help you with any of this, please feel free to contact me through my website: Airtable consulting — ScottWorld

the automation is based on conditions to activate and consequently send the email, one of these conditions is that "documents" is not empty and that the date of the document corresponds to the following month. It then automatically takes the url of the document and attaches it to the email, this worked until a month ago. being new to the airtable world, how can I fix this?

Hi @ScottWorld , could you please tell us why you don't recommend using Zappier?


The main problems that I have with Zapier are best described by discussing the main advantages that Make has over Zapier:

1. Make has none of the limitations that Zapier has. Just as one example out of hundreds of examples, Zapier only allows 3 conditional branches, whereas Make allows unlimited conditional branches. Also, Make has a purely visual drag-and-drop environment that makes it much easier to visualize entire automations.

2. Make is SIGNIFICANTLY more powerful than Zapier. Probably a million times more powerful. Lol. For example, Make has an entire library of hundreds of functions & tools built into the platform that let you manipulate your data -- including groups of Airtable records at once, which Zapier doesn't allow -- in ways that Zapier doesn't allow at all.

3. Make is SIGNIFICANTLY cheaper than Zapier, even though is is way more powerful than Zapier.

4. Make has much better tech support than Zapier.

However, the one downside to Make is that there can be a bit of a learning curve with Make, which is why I created this basic navigation video for Make, along with providing the link to Make’s free training courses. There are also many Make experts hanging out there who can answer other Make questions. 

Hmm could you try just re-setting up your automation and giving that a shot?  It seems to be working fine for me and perhaps setting the attachment field again would help

Screenshot 2023-06-16 at 3.24.31 PM.png
Link to base

I tried but it doesn't work. The test passes without problems, but trying the automation fails giving me the error of the url not allowed. I just don't get it. I don't enter the url of the attachment directly, but it takes it automatically because I have set conditions to ensure that the automation starts. This worked until last month.

4 - Data Explorer
4 - Data Explorer

I am having the same issue with one of my bases.  It isnt happening with others.  I noticed the interface for uploading images changed over the weekend but other than that.

It is set to email when it enters a view, I tried remaking the automation.

5 - Automation Enthusiast
5 - Automation Enthusiast

This JUST started happening to me as well!

It's been working forever, and now in the last week or so it stopped working!

5 - Automation Enthusiast
5 - Automation Enthusiast

If this changed in November of 2022, why is my automation breaking now?


Also, why does it work if I run the automation in a test, but not in the live environment?