"When a Button is Clicked" and "Trigger an Automation" button

Topic Labels: Automations
5157 7
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

I’m trying to use the (new-ish?) “When a Button is Clicked” automation trigger. The button is on an Interface in the same table as the Automation.

On the automation, the trigger’s configuration instructions are as follows;

This trigger is not currently associated with any buttons in an interface.
To connect:
Open an interface
Create or select a button
Select “Trigger an automation” under “Button Type” in the properties pane
Choose this automation from the list

In the interface, I have the “Button type” set to “Run Automation”
Under the “Table - Source” it says “Unconfigured Source,” with no options for the source.
The Automation option is grayed out.

So it seems like the button can’t find the Automation, but the Automation can’t be turned on because I need to fix the configuration…

Has anyone encountered this? I’m guessing I’m missing something quite simple but this is my first foray into the Interface Designer with Automations.

Thanks in advance.

7 Replies 7

Hmm, do you have any Record Picker elements in your interface? Those usually work as sources for me here

4 - Data Explorer
4 - Data Explorer

I’m having the same issue. Have you had any luck with this?

thanks for the tip. this worked for me. i added a placeholder Record Picker to my interface and then was able to finish configuring the button & turn on the automation.

my Record Picker element doesn’t have anything to do with the automation or the page that it’s on, but was necessary to get the button working

5 - Automation Enthusiast
5 - Automation Enthusiast

Hi! I was having the same issue. I added a placeholder Record Picker to my interface and am able to now choose the automation to assign to the button. But when I publish the interface, the button is greyed out - when I hover over the button, it says ‘invalid input’. When I go in to edit the interface, everything still looks good. I’ve tested the automation and it works fine, so I’m not sure what the issue is now. Does anyone have an idea?

Hi Deb, that sounds pretty weird. I’ve not experienced that before myself, and hopefully someone else can diagnose this

I’d be happy to take a look at this for you if you could DM me an invite as well

I've just hit this "Unconfigured Source" problem too - what the heck? How does this problem even exist... I just want to create an interface button that runs an automation that runs a script 😭😭😭

4 - Data Explorer
4 - Data Explorer

I had the same error, i solved it by doing the following:

  1. in the airtable automatons you create a new automation with the trigger "When a button is clicked".
  2. On the interface side, add a record picker and than add a button.
  3. Attach the Source of the button to that of the record picker.
  4. Choose the automation name you created in step 1 from the drop down.
  5. add the actions to your automation and than turn it on. 
  6. The button after publishing the interface should run the connected automation.

Hope that helps!