Re: Filterbyformula not working on Date functions or trouble with field name?

755 0
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

hey everyone,

I’m not sure why but I’m getting an empty result when using filterbyformula with a date function. I’m trying to receive all records that hold a certain date in a certain field. The field also might be empty on some records just if that matters, but I double checked there are records for these fields.

Here’s my query…


So i’m doing filterByFormula with "IS_SAME(“Datum Abb.”, “2021-12-06”)

I tried IS_AFTER and IS_BEFORE also to double check and even have more records to show but all I get is an empty result. I tried using other formulas on others fields that worked fine but I can’t get this to work. Am I overlooking something? Is the space in the field name causing any issues here? I mean it is URL encoded correctly but i’m still not sure if it could be an issue. I can’t simply change the field name due to other constraints…

1 Reply 1

That is not encoded properly.

Use Airtable’s API URL encoder tool to help you.

The link to a personally-customized version of this tool is available to you in the REST API documentation. Go into a base, then a table, then choose “List Records”.