Re: Mac OS Client Won't Load Scripting Block

Jump to Solution
1456 0
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

Hi Everyone,

I’ve been trying to script from the desktop Mac OS client. I believe it’s an electron app.

Unfortunately, any time I try to open the scripting block, it just hangs there and continues showing the loading wheel. I can run scripts, but I cannot edit them, I only see the loading wheel.

I saw this thread below:

My issue is similar, but I don’t get an error at all.

Any tips on how to fix this?

Thank you!

1 Solution

Accepted Solutions
7 - App Architect
7 - App Architect

Hey @Julian_Wan
have you tried clearing the cache?

Help -> Clear cache and reload

See Solution in Thread

5 Replies 5

I use the Mac desktop app almost exclusively (running Catalina 10.15.7), and never have issues with the Scripting app. What macOS version are you running? Does the Scripting app work fine when using Airtable in a browser, or do you have the same issues there?

Hi Justin,

Thanks for your reply.

I have two work machines:

  • M1 MacBook Pro running Big Sur 11.4
  • Mac Pro running Big Sur 11.4

Both show the scripting block in Chrome and Safari, it’s only the native Mac OS app that does not work.

This isn’t a huge problem, but there are two major reasons why I prefer the app:

  • Default Link Behavior: With the app, URLs don’t open in the same window (I have review scripts written for my team that require them to visit outside URLs. It’s easier for them to open in a new window or browser rather than the same window)

  • Memory Allocation: Call me crazy, but the native electron app seems faster in almost every regard, and I imagine that’s due better resource allocation closer to hardware… is that possible or am I nuts?

Here’s how my browser looks:

Airtable Browser

And here’s how the electron app hangs:

Stuck Loading

It never stops loading… Is it possible I have certain requirements not met? Or could my machine have dependencies that don’t match with what the app requires?

7 - App Architect
7 - App Architect

Hey @Julian_Wan
have you tried clearing the cache?

Help -> Clear cache and reload

I have a hunch that it’s one of those two things. In short, the browser that you’re using is likely optimized for Big Sur, but the Airtable desktop app isn’t. I recommend contacting Airtable support directly to ask when the desktop app will be updated to support Big Sur.

Um… that seems obvious in retrospect.

Thank you @Mariusz_S — that worked!

I kept hitting reload, but didn’t realize I could clear cache under the help menu!

My hobby and work projects will be supercharged once again!

It Worked!