Help

Welcome to the Airtable Community! If you're new here, check out our Getting Started area to get the most out of your community experience.

Scripting Changes Are Missing

Topic Labels: Scripting extentions
289 2
cancel
Showing results for 
Search instead for 
Did you mean: 

Hi,

I spent a good part of the day yesterday making changes and adding to a scripting block in my base. It was all working fine and was running from a button in a table. However, today I have discovered that all of my changes are gone and that the script is back to an old version!

I have looked at all recent base snapshots, looked through the trash, and tried undo/redo in the code editor but I all to no avail. I had another tab in my browser with the same base open so I am wondering if this prevented my changes from being permanently retained. I have contacted support about this but am wondering if the community has any tricks that might help. Anything is appreciated!

2 Replies 2

Welcome to the community, @VIMC_Manager! :grinning_face_with_big_eyes: I ran into something similar not long ago. I normally use the desktop app, but I had that app and a browser tab open to the same base at one point. Like you, I was working on a script, but I was doing it in the browser, and the changes didn’t sync to the desktop app for some reason. I closed the browser first, then refreshed the desktop app, but all of my code was gone. I ended up needing to redo all of that code (not a ton, but still annoying). I don’t know a way around this unfortunately. The snapshots that are saved are only of the base data, not anything in the apps.

Thanks for sharing your experience @Justin_Barrett . I think I will get in the habit of creating backups of any significant scripting work that I do, which will also be useful if I want to reuse script or refer to the code.

Hopefully others are able to avoid this same type of incident.!