Re: [SOLVED] Problem when creating a record with an attachment

94 0
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer


I’m trying to create a new record with the API. One field type is an attachment (an image or pdf).

My call is working, I have a 200 response code, I can see the new record in the Airtable interface, I also have in the response the attachment field information:

["Proof"]=> array(1) { [0]=> object(stdClass)#28 (3) { ["id"]=> string(17) "attOL0Pzidc5P8bOk" ["url"]=> string(85) "" ["filename"]=> string(36) "myfile.jpg" } }

but in the Airtable interface this field is empty, and if I get this new record, I don’t have this field. The file is first uploaded on my server, I can access the file in my browser using the URL.

In the documentation, it’s indicated that Airtable will download the file at the given URL and keep its own copy of it. I presume it’s not working?

Do you have an idea where the problem is?

Thank you

2 Replies 2

I tried with a public image from my website and it works but it doesn’t work with the image from my FTP (where files are also available with an URL)

It was an SSL certificate problem. It’s now fixed with an update of the certificate!