Help

Swapping Slack workspaces, but airtable automation shows old chanel list.

162 1
cancel
Showing results for 
Search instead for 
Did you mean: 
Brian_Hendel
6 - Interface Innovator
6 - Interface Innovator

Here's a weird one. So I had am automation set up using the airtable "Slack: Send a message" action and it always worked great. I add the slack workspace account, authorize, then it shows a chanel list of all chans, I pick my chan in the workspace. Good.

 

We created a completely new slack workspace since our product got split to another business and now I need to make this message get sent to the NEW Slack workspace. Simple. Go into the automation, remove the old Slack workspace integration, add the new one with the NEW slack URL and new user/pass, and then... wait... It is showing the OLD slack channel list from the old workspace. The channels are totally different so I must have made a mistake. I remove the "Slack: Send a message" action completely, then to Account -> Integrations section to remove the integration from my entire airtable profile. I notice that this integration DOES show the name of the NEW company, which isn't looking promising (since that means I did log into the right one) but I remove it anyway. Then go back, add the automation action, there is no Slack workspace added (good) so I add one again, and again, this time I type the NEW slack URL, with the new company credentials for the NEW slack, the channel drop down shows loading bar for a second and.... same... all the OLD channels form the OLD workspace that I am not even logged into.  I even tried to "Reconnect". I even tried flipping the "Channel / User" input box mode from Static to Dynamic and just typed a known channel name form the new workspace and no dice. Says it does not exist. 

 

My thought here is that the airtable devs have never tested a case where someone tried to log into a second Slack workspace, and somehow the old (removed) workspace is still sitting around in airtable. Maybe I am totally missing something but I've even checked the workspace names, etc. All point at the NEW workspace... 

 

Please Help! I have no next steps to solve this. I am happy to DM a video of my slack spaces and my AT confirm to any admins if that helps. I just don't want to post it here for security reasons.

1 Reply 1

I'd suggest opening a support ticket directly with them; might get you a faster response!