Re: URL Encode Formula Get Request Help

364 2
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

I’ve made a GPT assistant for e-com clients that can recommend products. This tool is made on The scenario is made with webhooks, open ai module (convert user query to airtable formula), search airtable records, open ai module (encode formula to URL) and airtable make an api call module.

Everthing works except the api module. I believe it's the URL because I have given my PAT every scope, connected it to the base, and have correctly connected it in 

The api module is a get request and I have used the list records url from the api documentation. 

I have tried these two forms of URL encoding and still no luck:


Any help would be greatly appreciated, thanks

5 Replies 5
18 - Pluto
18 - Pluto

The Airtable API URL Encoder Tool will help you, but you are actually doing it the hard way by writing your own HTTP requests.

Make has its own native Airtable modules for you to use, which don’t require you writing any of your own requests at all.

For example, to filter by formula, just use the Airtable Search Records module.

For additional Make training resources, check out this thread:

And I also give live demonstrations of how to use Make in many of my Airtable podcast appearances here:

p.s. If you’d like to hire an expert Airtable consultant to help you with anything Airtable-related, please feel free to contact me through my website: Airtable consulting — ScottWorld 

What's the error you get?  Could you provide screenshots of your error messages and setup? 

I tested the "filterByFormula" param and it works fine actually

I kept getting a 403 error

Hi Scott thanks for your reply. 

I should have provided more context and screenshots. This is my make scenario and the photos show the set up of each module in order. Webhooks gets user query. First open ai module converts it to an airtable formula. First airtable module uses the formula from first open ai module to find product right for user

Screenshot 2024-04-07 at 3.49.02 pm.pngScreenshot 2024-04-07 at 3.53.01 pm.pngScreenshot 2024-04-07 at 3.49.39 pm.pngScreenshot 2024-04-07 at 3.50.18 pm.pngScreenshot 2024-04-07 at 3.50.34 pm.png

I have used the second open ai module to try the standard way of URL encoding and I tried modeling off the airtable url encoding tool. 

Here is a test run I did.

Screenshot 2024-04-07 at 4.00.09 pm.pngScreenshot 2024-04-07 at 4.00.03 pm.pngScreenshot 2024-04-07 at 3.59.55 pm.pngScreenshot 2024-04-07 at 3.59.37 pm.pngScreenshot 2024-04-07 at 3.59.23 pm.png

How can I fix the error in the last step?


I have more context in my reply to Scott