Adding a string to any formula returns an error

Topic Labels: Formulas
679 1
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

For whatever reason, I cannot add text to a formula, even using the same formula I have running in other bases. Basically, I want the formula to return to values with a hyphen or colon between the two. I have two variables, Color (single-line text) and Brand (single select), and I want it to return like “Color - Brand” or Color: Brand.” I have tried the following formulas:

Color & “ - “ & Brand
Color & ‘ - ‘ & Brand
Concatenate(Color, " - " , Brand)
Concatenate(Color, ’ - ’ , Brand"

Each of these returns an error for an invalid formula. And, as I said, I have another base with an effectively identical formula and it works with no problems.

Further, I have tried moving the hyphen elsewhere and I’ve tried using different characters, none of which works. For example, if I just try to add a random word to the end of the formula, like the one below, I get the same error:

Color & Brand & “randomword”
Concatenate(Color, Brand, “randomword”)

These, too, return the same error. It’s like any string I include in the formula returns an error. I have to be doing something wrong, I just can’t figure out what that is.

1 Reply 1

Airtable’s formula box sucks, because it almost never tells people what actually went wrong. In your case, it’s possible that you are using curly quotes instead of straight quotes. The formula box doesn’t like curly quotes.