Help

Difference formula

Topic Labels: Formulas
Solved
Jump to Solution
479 5
cancel
Showing results for 
Search instead for 
Did you mean: 
Diane_Martinez
5 - Automation Enthusiast
5 - Automation Enthusiast

I’m hoping the community can help me out. I think that my formula is a bit off.

Here’s the logic I’m trying to do in the Difference field:

  1. If Baseline Value is empty, leave Difference empty
  2. If Baseline Value is 0, use the value in Target value
  3. If Baseline Value is NOT empty, calculate Target value minus Baseline value divided by Baseline value so I can get the percentage difference

Screen Shot 2022-08-31 at 4.16.42 PM
As you can see, if Baseline Value is 0 or empty, there’s an error

My current formula:

IF({Baseline} != BLANK(),
IF({Baseline value} != BLANK(),
  (INT({Target value}-{Baseline value})/{Baseline value}),
  IF({Baseline value} = 0,
    INT({Target value}),
  BLANK()
  )
)
1 Solution

Accepted Solutions
kuovonne
18 - Pluto
18 - Pluto
IF(
  {Baseline value} & "",
  IF(
    {Baseline value},
    ({Target value} - {Baseline value}) / {Baseline value},
    {Target value}
)

See Solution in Thread

5 Replies 5
Ben_Young1
10 - Mercury
10 - Mercury

Hey @Diane_Martinez!

Give this a shot:

IF(
    {Baseline},
    IF(
        {Baseline value} = 0,
        INT({Target value}),
        INT(({Target value} - {Baseline value}) / {Baseline value})
    )
)

I’m in the middle of working on your other post from earlier, so I’m online.
Let me know if you have any issues, or questions, or are curious to see what else you might want to do.


Edit:

kuovonne
18 - Pluto
18 - Pluto
IF(
  {Baseline value} & "",
  IF(
    {Baseline value},
    ({Target value} - {Baseline value}) / {Baseline value},
    {Target value}
)

Sorry, that came back with having errors

you absolutely rock @kuovonne
many many thanks

Just so that I can update my original reply with an edit, I was curious if your table has the {Baseline} field, or if it was supposed to be the {Baseline value} field.

IF({Baseline} != BLANK(),

When I tested it yesterday and configured it with the {Baseline} field, I returned this behavior:

image