Re: Need help removing a word, and also extra space between other words

2048 1
Showing results for 
Search instead for 
Did you mean: 
7 - App Architect
7 - App Architect

I have a field that is bringing in names using the web clipper block. The problem I am having is the names from the site come in with additional header, and extra space between them. Is there a way to clean this up in a formula or in the web clipper on import? Here is the example:

Clients:  Bob Jenkins     Sarah Hunter

I need it to look like this:

Bob Hunter, Sarah Hunter

Thanks as always!

15 Replies 15
7 - App Architect
7 - App Architect

So far none of the options have worked, and to answer the last question the names are variable and could be up to 6 people.

Can you be more specific when you say that “none of the options have worked”? Have they worked for some records but not for others? What exactly is the output from these formulas using your actual data? We can’t see what you see, so we don’t know what else to suggest unless you give us more detail.

That’s going to be your biggest problem. Both of the solutions provides so far will only work with two names, and were designed that way because the initial sample you provided only contained two names. To parse an arbitrary number of names up to six will require a much more complex solution. I’ve got some ideas on how to approach it, but having more detail from your end would help to focus our efforts in the right direction.

4 - Data Explorer
4 - Data Explorer

Hi, hope I’m not being rude by tagging into this thread ( first timer ). If so, I apologise in advance.

I have a similar issue with trying to remove the “.jpeg” filename from a bulk import of images I did into a new gallery. I uploaded 1,000 logos for a marketplace site I’m working on and instead of the company name in the Name Field I now have “company name.jpeg”.

!Airtable Issue|700x175](upload://5xD6KA0LRXOypa0arqO130uUDzb.jpeg)

Is there an easy way to remove the .jpeg from all 1,000 cells ?

Thanks in advance.

Your task seems a lot simpler. You may need only this: SUBSTITUTE({Name}, '.jpg', ''), which should replace any instance of ‘.jpg’ with nothing.

@Damon_Talbot Checking in to see if you’re able to provide the further insight that I asked for following your last response (above).

I never could get it to work and just moved on with a work around in my process.