Upcoming database upgrades. to improve our reliability at 03:30 UTC on Feb. 25 / 7:30pm PT on Feb. 24. Some users may briefly experience slow load times or error messages. Learn more here

All browsers freezing when expanding multiple records

909 16
Showing results for 
Search instead for 
Did you mean: 


We are currently experiencing freezing issues in our bases (not just one but multiple) and from different browsers in different OSs (windows 10, MacOS high Sierra, Safari, Chrome, Firefox) where the browser hangs immediately after trying to edit a couple of records using expanded records.

Is there anyone else experiencing this? it has only been happening today as the days before everything was fine.

We tried removing browser extensions, and as mentioned, it is happening to different users of our team in different operating systems and computers.

If someone has advice I would greatly appreciate it.

16 Replies 16

Not sure, but I would email about this, and please report back here with what they tell you!

Hi @ScottWorld

thanks for the answe.
I did that and the automated answer said they prioritise Enterprise customers (We are Pro, not enterprise) so I should go here to the forums for quicker answers.

I will definitely report back once support answers!

Great, please be sure to report back so we can all learn what’s going on with that issue! :slightly_smiling_face:

Yeah, that’s a really annoying & inauthentic auto-reply on those support messages, because the support message makes it seem like an official Airtable employee will get right back to you in these forums. In reality, they have nearly zero presence in the forums here. It’s just us fellow Airtable customers voluntarily helping each other out here, and Airtable very rarely chimes in here, if ever.

Justo got an answer from a support person saying that they needed to escalate the issue because they don’t know what is happening yet.

Will report again later if they say anything. So far we are still not able to use Airtable because after 1 minute of adding records is still freezing the browser tab.

This exact same issue is also happening within the company I work for, except we also tried using the desktop app. We also emailed support but have not yet heard anything… Did you get it resolved by chance?

Hi @Lauren_Scarborough we haven’t heard anything else after our last response from the support person. We are still waiting for the technical support which they said they were sending the ticket to, to reply.
I will update here as soon as I hear back from them.

Could you also please give me any updates it they answer to you?


Yes of course. I tried entering the records without expanding them along the lines and it seemed to work at first but now it is freezing again. Our support said they are hearing from many people that this issue is happening with “linked records” when you open one and then another within that record… We are trying to get around it but it has been difficult. I will definitely update with any news we get.
Thank you!

Same issue for me, also a Pro member. Everything freezes up when start to enter info into a new record.

@Juan_Arroyave1 @Tracie_McMillan

UPDATE: Support just confirmed that the issue has been resolved and it should be working now!

@Lauren_Scarborough thanks for the update!

On our side we haven’t got any confirmation but hopefully it is fine!

Thanks again for letting us know

We just got an update but it seems our support is hours behind yours @Lauren_Scarborough

I just got told there was a bug in the linked records and that engineers are working to fix it.

Maybe you sre enterprise and get fixes faster? Not sure but hopefully we will all have it fixed soon.

You are quite welcome, and yes, we got the same message earlier today. It took some time but they got it back up and running after we received that message. I am unsure of what plan we have but I know its either Pro or Enterprise because we currently have almost 7k records in our base.

Hope you guys get up and running smoothly soon.

It is not working. I understand this is primarily a problem in adding/making changes to linked records….but I need that functionality.

Thank you,

I filed a bug report too. Same thing - started today. Wasn’t like this yesterday.

Work around is having to go and add the new record in through the other record

It’s still not working for me. I am still having issues as of 10 minutes ago.

how can i transfre from airtable to my credit card or paypal ?