Calendar subscription link not working with Outlook Exchange

Topic Labels: Views
4492 8
Showing results for 
Search instead for 
Did you mean: 
7 - App Architect
7 - App Architect

I’m trying to view an Airtable calendar on Outlook.

FYI, we run an exchange server; I can access email and calendars via the desktop app (Microsoft Outlook for Mac v15.40) or OWA (Outlook Web App). I tried subscribing via this method:

It produces no results (the calendar is empty).

I’ve tested the same link in Google Calendars and Apple Calendar, and it works without issue. I’ve tested other calendar subscriptions in Exchange, and they all seem to work properly.

Has anyone else experienced this issue?

8 Replies 8

Just curious: does anyone have an example of an Airtable calendar subscription that DOES sync correctly with Outlook Exchange/OWA?

I was able to get a calendar to show up but it hasn’t updated since.

The best approach I’ve found is to subscribe to the airtable calendar in google calendars, then subscribe to that google calendar in Outlook. That seems to work fine, but apparently Google Calendars only updates subscriptions every 8 hours, so it takes a while for updates to sync.

And this is obviously a hassle, since it doubles the steps required to sync a calendar feed.

Airtable support has provided no help, thus far.

Thanks! @BenInDallas. That’s super helpful (though it would be great if it worked properly)

Thanks @BenInDallas for this post! I use Airtable to schedule for my clients and have been getting complaints that events weren’t showing up their Outlook calendar. If nothing else, it’s helpful to know that it’s not from us subscribing incorrectly.

I’m hopeful this bug can be fixed. Using Airtable is helping our efficiency so much, but this bug is a major issue for the way we communicate with our clients.

Hi, I am also trying to find the Airtable calendar on my Outlook account even I have tested the same link in other Calendars the link is working fine for those but not working in the only Outlook, anyone can suggest me the solution.

Having exactly the same behavior. It seems to be an Outlook issue, this [article]( say) says use “webcal://” instead of “https://” in the cal link. Did not help. For my project I am using now the airtable calendar web view, instead of the outlook calendar.

6 - Interface Innovator
6 - Interface Innovator

May be a little late to this but I found if you click "Manage connected accounts" and click a connected account you have already inputed and "Rename" it to something unique it worked.