Help

Upcoming database upgrades. Airtable functionality will be reduced for ~15 minutes at 06:00 UTC on Feb. 4 / 10:00 pm PT on Feb. 3. Learn more here

Copy and Paste Multi Select Options

Topic Labels: Sync
422 5
cancel
Showing results for 
Search instead for 
Did you mean: 

Hi, I want to be able to copy a group of multi select options from one record to another record on a different table. If I copy and paste, it makes one new multi select option in the new field of everything I copied over. How can I copy this over without having to add in each one individually?

airtable2
airtable 3

5 Replies 5

My recommendation: don’t try to do this in the expanded record view. Stay in the grid view for everything. Select the source cell and copy it. Move to the other table, select the destination cell, and paste. I’ve never run into the issue that you mention when migrating the values this way.

@Justin_Barrett Justin you have turned my whole day around! This was the most simple thing to try and it worked! I hope you have a wonderful day!!

@Haley_Lopez It would be nice if this same behavior existed in the expanded view. You might want to email support@airtable.com to ask them about making this behavior act the same across both views.

@ScottWorld Agreed and will do, good idea!!

Hi,

I think, the whole behavior of ‘paste’ should be improved. For example, when ‘Alt’ pressed together with Ctrl+V (or Shift+Ins), then commas and ‘&’-chars copied as usual part of text values and don’t used as delimiter.

typical use case - I create a new linked field to a new table and copy-paste some field there. A very powerful Airtable ability, that can be used to : create a summary list with totals for each unique value in field, find duplicates and their count, build vlookup relations by non-primary fields. Just a simple manual action without coding and without automations.
The only thing that spoil result - when a value has comma or ‘&’, it splits. It’s a cool feature itself - you can use a single line of comma-separated values to create a multiple linked records. But sometimes comma must remain as a comma inside value…
Currently, I’m using workaround with additional substitute formula field. like substitute comma with [comma] and after copying, substitute back.

Maybe it’s a good suggestion for support, but I just want to be sure that I don’t miss something - what if such key already exists?

NOTE: (wow!) while writing this reply, I just tested non-obvious feature and very excited that it worked - if you copy-paste record id (or several record ids) into linked field, and such record(s) exists in target table, it links to it !!

Example.
I removed one record to show difference

image

Here is my copy-paste fields

image

It works! Deleted record id behave as usual text value - added to target table

image

So, the question of linking between 2 tables by any field might considered solved, even when each of both tables has non-unique primary field. Copy-paste ‘any field’ into new link to new _temp table, in both tables. Get column of IDs via ‘lookup of lookup’, turn it to links.