Upcoming database upgrades. Airtable functionality will be reduced for ~15 minutes at 06:00 UTC on Feb. 4 / 10:00 pm PT on Feb. 3. Learn more here

! Google login is no longer working on desktop app!

2445 25
Showing results for 
Search instead for 
Did you mean: 

Using the google sign-on in the desktop app now shows an error from Google: “This browser or app is not secure” and then does not allow logging in

Please resolve

25 Replies 25

Also experiencing this! Even allowing less secure apps with my Google account and reinstalling Airtable didn’t seem to help.

I just logged in on the Windows desktop app using Google without issue. Are you using Windows or Mac? (Also this is probably something you should consult with support directly if the problem persists)

I think this is related to the platform outage earlier. I noticed that the security context of every browser instance was reset and had to be logged in again. This suggests something turbulent occurred at the DNS level.

+1 to this post. Having the same issue on Mac. Checked all security preferences and found nothing that could interfere on my end. Following…

Hi @Bill.French

As in security breach.


Um, I have not seen any evidence of any security breach. Simply pointing out that their servers required a fresh login when they recovered from the outage.

Same issue here. Just signed up for pro and bummed I can’t use the app.

I think it’s a google issue. I made a new account where I don’t sign in through google and it works.

Following so that I can follow up on a resolution. Same issue here.

Darin, I got it to log on asking to reset my password. I put my email (gmail), asked to reset my password, I reset and log on. Super simple, I got it just doing this. Try again and say me :grinning_face_with_big_eyes:

Yeah, I’m not resetting my password for this. It’s clearly a glitch of some sort and if I had to reset it every time I wanted to log on I’d probably just give up.

Checked all security preferences and found nothing that could interfere on my end. Following…


I had the same issue, check if your Airtable’s password is saved into your Google Chrome settings, then just put your e-mail (Gmail) and password into the common login form.

It worked for me !

Have a good day dudes

Hi Robin - I’m afraid that won’t work - the issue here is not signing into an AirTable account, it’s for users that use a Third Party login (i.e. you sign in with your Google account) - thanks for the attempt though!

I’m surprised that this is still an issue after two weeks - it seems like a pretty big problem, not being able to log in.

I’ve tried just creating an AirTable password, but it doesn’t let you when you’ve already got an account through a third party…

Can the Admins please respond with an update on this?

Hello, exactly the same issue. I discussed a bit with support and show them the issue (like 2 weeks ago) but nothing…

The desktop app is a must-have and it’s becoming embarrassing!

Also having this issue with the Mac desktop app, but not the iOS mobile app.

Error message same as described above (thanks, Darin); full error message is as follows: “Couldn’t sign you in This browser or app may not be secure. Try using a different browser. If you’re already using a supported browser, you can refresh your screen and try again to sign in.” My google account is set to allow sign-in to Airtable.

Unfortunately, still same here…

Popped in to say same issue for me - Google login does not work on desktop app. I was able to log in (to post this comment) fine in Chrome using Google login.

My solution for this:

  1. Login to your Airtable account via website (e.g. Google Chrome)
  2. Click your profile picture → Account

You should see a button to add an Airtable Password to your account (to the right of your profile picture)

  1. Add another password to your Airtable.
  2. Open up the desktop app and login with the email from your Gmail and the Password you have just created.

It should be done from there! Good luck!