Integromat - tried it?

Topic Labels: Integrations
11255 27
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

Did anybody hear about this before / try it?

Airtable Integrations

Integromat gives you the ability to integrate Airtable with many other services.

27 Replies 27
7 - App Architect
7 - App Architect

No but its on the list to try!

5 - Automation Enthusiast
5 - Automation Enthusiast

Yes I have been testing by comparing with Zapier.

Firstly word of warning. The Integromat design console does not guide one step by step in the way that Zapier does when creating a new integration. In the later only one record can be updated during the test step. With Integromat one can (unintentionally) update all or many records if your configuration is not correct or completed. Therefore use a test Airtable database to experiment with.

My most common integration is from form-related data in Google Sheets to Airtable so this is where I am exploring initially. Zapier detects if there is either a new row or an updated GS row but Integromat only looks for new rows. Integromat does not work with Airtable views. Integromat says it can update Airtable records. Not tried yet but will as you can’t do this in Zapier as far as I know.

There are many more places in Integromat to set filters or conditions. The UI is very different from Zapier’s and I like the way that the data-flows resulting from a trigger are depicted graphically.

Integromat has a free limit of 1000 operations per month as opposed to Zapier’s 100. This is a major benefit for keeping our non-profit organisation’s database current.

That’s all for now folks.

Similarly, I tried Integromat a couple of times and couldn’t understand how to put an automation together. :grimacing: Not intuitive, and hard to figure out.

The graphical depiction is awesome (in theory at least).

The only point of difference with @Kim_Prisk post, Zapier can update records in Airtable, but it requires a multi-step Zap via a paid Zapier account.

Unless you somehow know which RECORD_ID() to update.

4 - Data Explorer
4 - Data Explorer

Hey guys,

I’m struggling with Integromat in updating a record. The search works fine but the update action always shows an error. Attached screenshot. Any help will be greatly appreciated. Thanks in advance!



I have tried Integromat and I think it’s very promising indeed.

For a project, I was looking to be able to move photos out of a database (not Airtable this time), resize them, store them in Google Drive and then add a link back to them in the database. I couldn’t get this to work with Zapier for several reasons so searched for an alternative. I was able to do this in a free Integromat account in about 5 minutes!

Other advantages over Zapier include the ability to have branching logic (equivalent to If… ElseIf… Else…) and to inherently handle multiple returned values and perform subsequent steps for all of them (which is only possible in Zapier using some code). A downside, though, is that it doesn’t have as many connections yet.

HOWEVER, for Airtable users there is a problem in that the interface is limited and buggy at the moment. I contacted them via their support site and received the following response from their CEO (no less):

Airtable has a private part of API which is (for example) used by Zapier. The thing is, that Airtable is not allowing us to access the private part of their API. So what we did is that we used some workarounds to be able to do at least some of the actions from their private API. Unfortunately, this workaround is very limited and that’s why you are seeing this errors.
We can’t do anything about that before they will provide us with the access to their full API. We are requesting regularly, but so far no luck :frowning:

I have no way of knowing if this is correct or not but I emailed Airtable to find out more and have yet to receive a response (but it’s only been a couple of days).

I came across these errors when I started to prepare a review of Integromat for my blog (, intending to go through some use cases with both Airtable and, potentially, another database, but these errors caused me to delay. I prefer to use Airtable as the main platform in this type of review because it’s so visual and also quick to configure. I may have to base my review on the other database and edit it later - if and when the problems are resolved.

Hey Julian, thanks a lot for your response. Yes it does seem like Airtable
doesn’t want to support Integromat. Where I wrote to their support, they
simply said it’s beyond their scope of knowledge. Integromat is freaking
awesome but Zapier clearly has Aces up its sleeves.

I think you may be right - there seems to be a good relationship with Zapier (who are market leaders in this space) and I wouldn’t be that surprised to find there was some kind of agreement there - which would be quite sensible on Airtable’s part.

However, in a competitive market, newer entrants with great features tend to push market leaders to up their game - so maybe we’ll see some improvements to Zapier in due course.

I would like Integromat to work with Airtable properly though - there are things it does right now which can’t be done in a Zap.


I am having similar issues with Integromat. One suggestion (from Integromat support) was to upload data to datastore module and than proceed to setting up a module/scenario from there. Having said that, I seem to be getting errors, too. I would like to use Integromat and hopefully Airtable will cooperate with there API access with Integromat, otherwise it would be a shame to not have another option, which seems to be more of what I am looking for.

A bit of a heads up, an Airtable user set up a video using Airtable and Integromat:

Hope this helps.


I hope I set this link up correctly.

4 - Data Explorer
4 - Data Explorer

I use Integromatic for connect Google Sheet to Airtable.
why Integromatic and not Zaper?


4 - Data Explorer
4 - Data Explorer

And the connection is very easy:


I recently built an interface between Airtable and the USPS Address Validation API using Integromat. The parts that were straightforward went swimmingly, and I’m a huge fan of their UI. The parts that weren’t straightforward remain impenetrable. There are fields and variables that go undefined throughout the documentation, and I’m sure there are far more elegant methods of doing what I did — but I couldn’t find decent example code or tutorials to help me muddle through.

Admittedly, comparing Integromat to Zapier in terms of documentary support isn’t really fair — for that matter, comparing virtually anyone to Zapier isn’t all that fair, as Zapier has one of the best technical/technical marketing writing teams ever assembled. That said, Integromat’s recent decision to shutter their support forums and direct their users to the company’s Facebook page instead can only be viewed as an unforced own goal.

6 - Interface Innovator
6 - Interface Innovator

Trying to set up Integromat integration for new row in excel table to new record in Airtable. The fetching of records from excel works but I get an error “Value “null” is not a valid record ID.” on Airtable side and can’t understand what I’m doing wrong.

Hi @Krisjanis_Dzalbe1

Do you have some screenshots of the whole scenario? Also, the individual modules that you are using?

It might help.

Thank you,
Mary K

Tried to run just the airtable module only and the problem occurs with the field which is a link to a record in another table.

Hi @Krisjanis_Dzalbe1

Without being able to see the fields, in the first two modules, it’s a little bit hard to see what field is creating the error.

Hopefully, these two replies will help, together with some screenshots.

Take a look at this post, reply #2:

Also, try this link, post# 21:

These are screenshots of how your scenario might look like, without the Google Sheet module:

!image (upload://f7SBdP1mgJuOtAhHcMMSgzmIe6c.png) image image image image image

Thanks! I tried it out and it works as long as I leave the linked field empty.
So to localize the question how do I correctly map the linked record field?
airtable integromat.JPG

Hi @Krisjanis_Dzalbe1

I am glad it works for you.

To fill in that field, try selecting the very small box on top of the field. Once you do that, you should be able to fill in the field.

Mary K

Like this:


Thanks. I did switch the “map” toggle and choose the necessary value from the excel file before and got the error “Value is not a valid record ID”. Even though the value matches a record ID in the linked table.
at im.JPG at integromat.JPG

11 - Venus
11 - Venus

Hi @Krisjanis_Dzalbe1

What does the value look like? It comes from Excel, correct.

How about the formula? Is it written correctly? Although, it might not be that, unless it’s the unique key.

Did you check to make sure that the value is written correctly, in Excel and Airtable?

You should make sure that the field name from both Excel and Airtable match correctly.

If it has to do with a field value it could be the smallest thing, either a misspelling or an extra space, especially at the end.

I am just trying to think of different things to check.

If you could take screenshots of the value in Excel and in Airtable, that might help. Otherwise I am just kind of guessing.

Did you create a new TIME CREATED field in Airtable? Apparently, Airtable requires this field to process the data.

Did you mention that you had linked tables, (two tables together?). If so, are they linked correctly?

I hope these suggestions might help.

I have had situations that I would spend time clecking everything, sometimes a bunch of times.

Mary Kay